Bubble Witch Saga 3 Industrial Deals Beauty Little FIres Everywhere Shop new men's suiting nav_sap_plcc_ascpsc Learn more about Amazon Music Unlimited GNO for iPhone 8 Starting at $39.99 Grocery Handmade Tote Bags Book a house cleaner for 2 or more hours on Amazon Transparent Transparent Transparent  Introducing Echo Show Introducing All-New Fire HD 10 with Alexa hands-free $149.99 Kindle Oasis, unlike any Kindle you've ever held Trade in. Get paid. Go shopping. Shop Now FFII_gno
Customer Discussions > Kindle forum

wifi connected but showing "x" in signal strength in status bar


Sort: Oldest first | Newest first
Showing 1-25 of 76 posts in this discussion
Initial post: Jan 26, 2012, 8:49:41 PM PST
jen_in_co says:
I have a Kindle Fire that connects with no problem to my home wireless. I recently tried to connect to our apartments wifi at our pool/rec area. I asked to be sure, no passwords, etc needed. The Fire seemed to connect effortlessly, as said "connected" and that signal strength was "good." However, an "x" remained on the signal strength indicator on the status bar at the top right. I tried, just in case, to bring up the Internet, e-mail & buy an app but all failed. So, I did a reboot of my Fire holding the on/off button for 20 seconds. Same as before, x on signal, wifi said connected & good, couldn't connect to 3 things mentioned above. It reconnected to my home network with no problems. I have no issues with this network whatsoever. I know probably something simple I'm not doing! Thank you in advance for helping!

Posted on Jan 27, 2012, 3:09:15 AM PST
Fud53 says:
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

In reply to an earlier post on Jan 27, 2012, 3:18:40 AM PST
Last edited by the author on Jan 27, 2012, 3:21:44 AM PST
Jazzy_Jeff says:
Just put Fud53 on ignore. He, she or it tries to be mean and unhelpful as possible. As for your problem, it is hard to say. The router they are using could be an older one that needs a firmware update. Their router might just need a reboot. Without knowing what router it is we can only guess.

Posted on Jan 27, 2012, 7:53:09 AM PST
I am having the same issue. I have a 2wire router and have had no issues until the software update. It generally doesn't connect at all, it gets stuck on Obtaining IP Address (never an issue prior to the update) so I added the ip address and router info in the settings and it worked for an hour or so but now I have the "x" next to the strength bars. I don't want to reset to factory settings because I have hundreds of documents I've emailed to myself over the last month.

Posted on Jan 27, 2012, 7:59:37 AM PST
[Deleted by the author on Aug 19, 2016, 6:47:15 AM PDT]

Posted on Jan 27, 2012, 10:47:41 AM PST
jen_in_co says:
Jazzy_Jeff & T. Cook: Thank you for being helpful. Luke - I hope they can help us!! Yes, I will be putting Fud53 on ignore... I think it's obvious what problem I have and what "question" I need answering :) Sad that when you try to be as detailed as possible, someone can still always be make an ass of themselves trying to make you look bad. Moving on now! As for what router the office has set up, I have no idea, but I will investigate and see what I can find out. We were just told when we moved in that the "common areas" had free wifi, no password needed. Amazing how probably the most important info was left out of that. Anyway, I do know that I tried this before the software update we received i that helps some. I may be doing this all totally wrong but this is what I did when I tried to connect to that router. I accessed the wifi in the Fire by the gear at the top right in the status bar, then chose the wifi tab/button, wireless networking came up and after a few it listed all available around me. I chose the one for the rec area I was trying to access. It is there it seemed to work and connect and when I noticed the "x" up at the signal strength. When I tapped on that network to see the details that it came up and said, "status: connected", "signal strength: good" etc, but still the "x".

T. Cook: If I reset to factory settings would I then have to re-download all I've bought, such as books, apps. I'm really not trying to ask stupid questions, just making sure I understand everything! I'll definitely try it if it would help. I didn't assign anything, I don't know how to do that! Ugh, I feel like an idiot! I did reboot the Kindle holding the on/off button for 20 seconds, that didn't help, do I need to try something different that way? Also, when that connection didn't work, yes I did "forget" that connection.

Thank you all for helping me figure this out and for the record, "HOW DO I FIX THIS ISSUE AND GET MY FIRE TO CONNECT PROPERLY?" Is that question appropriate?! LOL, sorry couldn't resist!!

Posted on Jan 27, 2012, 11:38:15 AM PST
eric j ward says:
Same problem. Works fine at home, but only in about half of the public (restaurant, cafes, etc) networks I've tried.

Posted on Jan 27, 2012, 8:16:26 PM PST
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

In reply to an earlier post on Jan 27, 2012, 9:07:31 PM PST
jen_in_co says:
You give us hope then! I'm sure it's got to be something simple, just have to figure that out. Thanks for posting so I do know there are some with no problems! I'll keep working on it.

Posted on Feb 4, 2012, 7:21:26 PM PST
jen_in_co says:
Please read original post...any new thoughts on this? Thanks in advance for any help.

Posted on Mar 13, 2012, 7:32:33 AM PDT
AAAAHHHHH!!! Just got off with tech support for the same issue. I very nicely tried to tell the woman that I had 2 kindle fires currently in use in my office and one was connected and the other had the X by it. We have turned the one with the x off and on, unconnected and reconnected. She kept trying to say that it was a problem with my router and internet provider but could not explain why one was working and the other was not. The tech support obviously had no idea what she was talking about and just talking me through a script. So frustrated. Sorry just had to vent.

Posted on Mar 13, 2012, 8:22:54 AM PDT
art says:
If you have the x that means you are connected to the local network via the access point, but the Fire can't connect to the internet (it must ping some test address). You may have some dhcp issue on your local network so that it is handing out an incorrect default gateway. Perhaps you have two devices passing out addresses -- one your actual router (which would probably hand out its own address, which would be correct) and also another access point (which could hand out its own address too, which would be incorrect). It could be somewhat random which of these dhcp servers answers you, so you could even get mixed results in this situation! This could explain Michael's situation, since one Fire could be bound to one DHCP server and the other bound to the other -- and during the lease time they will not change dhcp servers on their own.

Digging into this in detail requires some knowledge of dhcp, what dhcp servers you have, and IP networking, but I suggest the following troubleshooting:

1. make sure you know what devices on your network can serve dhcp, and make sure only one is doing it, and that it is configured to supply correct information for netmasks, gateways, and addresses.

2. Consider trying a static address -- chances are even if your dhcp server can serve up 254 addresses or so, you're only using a few; look at your dhcp server to see what ones have been handed out and pick one way above the used addresses. Manually set the chosen address, correct netmask and gateway on your Fire.

2a. if that works, you can try to figure out why your dhcp server is handing out bad information, try updating your router firmware to correct its behavior, statically assign the address and other information if your router has this capability, or change the dhcp server's address range to give you a usable static address for your Fire that will not be handed out by DHCP, and stick with the static address (but this is a pain if you take the Fire elsewhere).

Posted on Apr 26, 2012, 9:50:29 AM PDT
JJY says:
I had the same problem. Found turning wifi off on my cell phone, then toggling wifi off then on on my fire fixed it. Turned wifi back on on my phone and all is well.

Posted on Apr 26, 2012, 10:48:20 AM PDT
emily swan says:
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

In reply to an earlier post on Apr 26, 2012, 10:56:41 AM PDT
Last edited by the author on Apr 26, 2012, 10:58:36 AM PDT
@emily, sorry, nope. When you have an 'x' by your WiFi icon, you cannot access anything on the internet, like your email, interactive games, Amazon's store, your Cloud content, streaming music and video, etc. It is a major problem.

In reply to an earlier post on Apr 26, 2012, 11:07:08 AM PDT
jen_in_co says:
@emily - no, it's not connected, thus the "x". When that "x" is present, you cannot connect to the internet, download mail, etc. Thus, being able to take it with me and maintain a connection is useless until I get this figured out.

In reply to an earlier post on Apr 26, 2012, 11:08:49 AM PDT
jen_in_co says:
@JJY - I have a very simple cell phone... and when I say simple, I mean it makes & receives calls & that's about it. I have no camera, no internet access, nothing!!! It's kind of nice for it to be so simple! LOL Anyway, just wondering are you using your phone as your hot spot to connect your kindle to the internet?

Posted on Apr 26, 2012, 11:09:51 AM PDT
jen_in_co says:
@Wild - totally agree on the major problem part. No, technically I don't have to take it with me, but it is nice to be able to be there and have access to everything!

In reply to an earlier post on Apr 26, 2012, 11:18:12 AM PDT
jen_in_co says:
@art - thanks for all of the help. I wish that I had all of that information, but considering this is through my apartment complex's office, what I can get to is very limited. It's not like it's my personal internet connection with router and all in my individual apartment. I have tried since then several times to get it to connect when I've been at the pool, but same problem, an "x". I did ask if to try to get more information about the modem/router or whatever equipment my complex has, but was denied and again told no password was needed. Without going into details, those in the office aren't that bright and are more concerned about getting one out of the office or off the phone... so I'll probably just have to read what I already have downloaded and not worry about having access... We'll be moving in a the fall, thank goodness!!!

Posted on Aug 19, 2012, 5:56:43 PM PDT
Gregory says:
Having this problem as well, Amazon offers no solution? Every other device on the wireless network works as it should, except the Fire. This new problem, added to other it's other issues, I'm realizing I should have bought another reader.
Your reply to Gregory's post:
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
 

Posted on Aug 19, 2012, 6:08:33 PM PDT
ty says:
You are connected to the router, but, internet is not being sent back, this could be due to compatibility issues, network failure or bad connection.

In reply to an earlier post on Aug 19, 2012, 6:19:52 PM PDT
I get this all the time. It doesn't appear to be the Fire's fault; when I get that X, NOTHING in the house can get online, although the wi-fi signal shows "good'. It's the actual internet connection. I have re-set my modem,and that sometimes works. But it seems to be my isp, not the Fire.

By the way, the Fire's not a reader. It's a media tablet with a book app.

In reply to an earlier post on Aug 19, 2012, 6:58:17 PM PDT
iDRMRSR says:
I get this intermittently all the time. Here's what I think happens...it got much worse after I installed the Go Launcher and app store and started loading up non-Amazon apps. I believe the newer versions of apps that you get from 1mobile and getjar and the go store cause problems with the KF's connection. For example, I can browse the web with Dolphin, and if I quit that and go to USA Today, USA Today won't refresh and I'll get the X. The other symptom is that the "beamer" icon flickers, indicating that the signal strength dipped and then went back up. But I'm sitting 20 feet from the router, that's impossible. What I think is happening is a "rogue app" is causing the device to lose the connection to the DNS or the Internet, possibly by flooding it with requests. I can get back on if I turn WIFI off, wait a few seconds, and turn it back on. I have to do this nearly every time I switch between non-Amazon app versions. The router and cable modem are brand new, btw, in the last couple of months.

Posted on Aug 19, 2012, 7:26:28 PM PDT
jen_in_co says:
I don't use "rouge apps" so I have no idea about that!

I asked others trying to connect at our pool area & everyone had issues - some had Kindle Fire's, some had ipad's & other types of reader's & tablets. The management swore wasn't a problem with their equipment & refused to reset. Those who live there still are on their own as we literally moved across the country in June & as we traveled (from Tennessee to Colorado) I had ABSOLUTELY NO ISSUES with my Kindle Fire as we stopped at different hotels each night - I connected without any problems. I think it does have something to do with routers & such but I'm definitely not skilled in that area. Hope all figure out their issues as I've not had any other problems & I love my Kindle Fire!

In reply to an earlier post on Aug 20, 2012, 6:45:26 AM PDT
Hmmmn...I don't have ANY non-Amazon apps (you mean not bought from Amazon store, right?), but I still get this intermittently too. I think next time it happens, I'll view "running apps", stop or even delete them and see if the wi-fi clears.

It still seems odd that ALL of our web devices in the house would not connect at the same time.
‹ Previous 1 2 3 4 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
FREE Books & Chat - September 2017 586 7 hours ago
We're Quirky! There Are Various Critters, Including Tail-less Manx Kittens, Here. We Also Have Hugh Manatee. Bring Your Quilting And Sewing Projects, Your Camera, And Your Instant Pot. So Geese And Tally Ho! 4492 7 hours ago
Whispersync only working one way. 5 7 hours ago
kindle fire it sucks and blows 385 7 hours ago
Elephants Three at The Ģrandest Hotel - Part IV 6623 8 hours ago
why cant i watch hulu o. my kindle fire? 32 8 hours ago
Kindle app disappeared 39 9 hours ago
Kindle Fire HD owners: Does USB host mode work? 37 9 hours ago
Error: network_error 23 10 hours ago
How to change to black background and white letters? 107 10 hours ago
 

This discussion

Discussion in:  Kindle forum
Participants:  57
Total posts:  76
Initial post:  Jan 26, 2012
Latest post:  Jul 9, 2017

New! Receive e-mail when new posts are made.
Tracked by 19 customers