Amazon Vehicles Editors' Picks Amazon Fashion Learn more Discover it Britney Spears Fire TV Stick Health, Household and Grocery Back to School Totes Summer-Event-Garden Amazon Cash Back Offer ElvisandNixon ElvisandNixon ElvisandNixon  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis Celine Dion Shop Now STEM
Customer Discussions > Kindle forum

Book won't download to Kindle App


Sort: Oldest first | Newest first
Showing 1-25 of 225 posts in this discussion
Initial post: Sep 18, 2012 3:18:45 AM PDT
Y. I. Asif says:
I just downloaded the Kindle App to my Android and purchased a book off the Amazon website. I've registered my 'Kindle' and the website is telling me that it has been sent to me and will be downloaded but it hasn't, and it won't appear on the App. Does anyone know how to fix this because it isn't there at all, not in Archives or the Home screen where it should be...

In reply to an earlier post on Sep 18, 2012 3:40:51 AM PDT
Denis Powell says:
Are you sure the App is registered to the same account you bought the book from?

Go to the Manage Your Kindle page, find the book and see if the Tablet App is one of the options you can send to under "Actions".

Posted on Sep 18, 2012 4:40:32 AM PDT
onewac says:
Did you click the On Device next to the Home button? On my Home screen it says I have no books on my device but if I click the device they show up. The app needs some polishing I think, it is buggy

Posted on Nov 10, 2012 11:09:30 PM PST
T. Inman says:
Go to the upright corner of the kindle app and make sure to manually sync.

Posted on Nov 20, 2012 8:10:49 PM PST
Last edited by the author on Nov 20, 2012 8:12:04 PM PST
I have been having the same problem with the app. Also, if I remove a book from the device, it does not go to the archive, it just disappears. It is the same account I bought the book from and I tried manually syncing.

Posted on Dec 4, 2012 9:05:24 AM PST
Same issue! I've tried all suggestions and nothing works. This is very frustrating!

Posted on Dec 10, 2012 6:12:25 PM PST
Noland Smith says:
I am having the the same problem. I have tried manually syncing and the accounts match up. Any advice will help

Posted on Dec 23, 2012 8:16:02 AM PST
I'm have the same problem with 4 books which I have purchased. Everything is registered properly (I haven't changed anything and all the previous books I purchased downloaded fine). All of a sudden, every time I try downloading a book to my Kindle for Mac application, I get the message, "Unable to download the book .... Please try again later." I've tried a number of times over a couple of days and they just won't download.

Posted on Dec 30, 2012 12:30:54 PM PST
S. Johnson says:
Has anyone found a solution to this problem? I have 2 books that won't sync.

Posted on Feb 3, 2013 3:21:12 PM PST
L. E. Q. says:
I have the same problem, none of the suggestions work.

Posted on Feb 7, 2013 4:15:36 AM PST
I try to download my book or even rebuy it in the store but it wont work it just says ive already bout it

Posted on Feb 7, 2013 4:18:35 AM PST
Sarida says:
Have you looked at your "Manage My Kindle" web page to see if it was actually purchased? If you see it there, try sending it to your device again.

Posted on Feb 18, 2013 4:32:42 PM PST
I'm using the send to Kindle and it won't let me send books to my Kindle for Mac or the Cloud Reader app I just downloaded. They don't come up at all in Send to Kindle and when I try to transfer them from the Kindle library page, I click "Deliver to My" and they both come up as options, but are grayed out and won't let me select them.

In reply to an earlier post on Feb 19, 2013 6:06:53 PM PST
Douglas Sink says:
My google android tablet appeared to download all of my archived books from Kindle, but they will not load when I click on the cover. No text appears.

In reply to an earlier post on Feb 26, 2013 5:05:38 PM PST
I had to go to my applicarion manager and erase the data from this app. Then when i reregistered it eveything was in my archieve

Posted on Mar 1, 2013 1:12:24 AM PST
2emkay says:
My Kindle desktop app does not download the books I bought, while my kindle app on the ipad works fine. Why?!!

Posted on Mar 2, 2013 6:07:12 PM PST
if you have and android smart phone this might work. I went to Google play and updated my kindle app. Now my books I just bought are now in the archives.

Posted on Mar 9, 2013 6:28:13 PM PST
Layla says:
My kindle app will not download any books i have tried everything. Help please

Posted on Mar 13, 2013 2:44:33 PM PDT
Emma says:
Hi, I just came onto to this page by 'google search' coz i was having the same problem (just bought an ebook on Amazon for my Nexus 7 and it wouldn't download) ; problem fixed after a bit of searching, here's how (it's a translation from french coz all my accounts are in french so there may be some approximation) : 1) download kindle app (free) 2) register kindle app 3)buy kindle book on amazon 4) go onto amazon.com , "your account" 5) go onto your kindle account (inside your amazon account;no registration necessary , it's linked to your amazon account once you've downloaded the app) 6) your kindle library will appear 7) select line of purchased book 8) at the right end of the line is a button "actions" 9) click on "actions 10) click on send to whatever (android device in my case)******** Hope this is helpfull; not giving full marks to amazon for intuitivity nor for communication (somebody from amazon should look at this forum once in a while).

In reply to an earlier post on Mar 16, 2013 5:23:33 PM PDT
LLP Pasadena says:
I did all that, and the books still don't show up on my Mac.

In reply to an earlier post on Mar 16, 2013 6:00:07 PM PDT
LLP Pasadena says:
Moved my old copy of Kindle for Mac to the trash and downloaded a new copy of the app and resynced. Works fine now.

In reply to an earlier post on Mar 18, 2013 9:59:58 AM PDT
M. Yeo says:
I deleted Kindle for Android on my smartphone, reinstalled the app and was able to re-download all of my purchases including the one that would not download.

In reply to an earlier post on Mar 20, 2013 3:11:40 PM PDT
Emilie says:
THANK YOU

Posted on Apr 27, 2013 1:54:00 AM PDT
Karen says:
Any further advice? I have tried everything including following etudient infirmier's advice, and although it says on my Kindle account that the book has been delivered, all I get on my ipad Kindle app is a greyed out book cover and 0.0% downloaded... I have de and registered the ipad Kindle app and nothing changes. Help....

Posted on May 6, 2013 8:03:18 AM PDT
Karen, I'm having the exact same problem. Manage my Kindle says it's been delivered, both to iPad and PC, but on iPad it's a greyed out bookcover/0% downloaded, and just doesn't exist on PC. Help....:)
‹ Previous 1 2 3 4 5 6 7 8 9 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
86th RAoK - Let the Games Begin 4432 2 minutes ago
I was deleting books from my cloud & I delete my Jimmy Swagger bible. Is there any way I can get it backk 155 4 minutes ago
How can I read books from amazon.co.jp on a UK purchased Kindle Fire HD 10? 1 7 minutes ago
authentication problem, how to fix? 19 12 minutes ago
non-fiction in Kindle First 7 14 minutes ago
low memory 2 22 minutes ago
Kindle Fire HD 7" sluggish and slow response? 249 23 minutes ago
Suggestions for Kindle features 715 23 minutes ago
We're Quirky And We Know It! Come Witness The Howling Dink, Hussy Turkey Hens, And A Veritable Plethora Of Other Beasts! So Geese! 5782 23 minutes ago
Whispersync not working for "household member" 1 28 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  144
Total posts:  225
Initial post:  Sep 18, 2012
Latest post:  1 day ago

New! Receive e-mail when new posts are made.
Tracked by 38 customers

Search Customer Discussions