Beauty Oprah's Book Club STEM nav_sap_plcc_ascpsc All-New Fire 7, starting at $49.99 Starting at $39.99 Wickedly Prime Handmade Wedding Rustic Decor Shop Popular Services TheTick TheTick TheTick  Introducing Echo Show All-New Fire HD 8, starting at $79.99 Kindle Oasis GNO Water Sports toystl17_gno
Customer Discussions > Kindle forum

kindle for pc won't open


Sort: Oldest first | Newest first
Showing 76-100 of 182 posts in this discussion
In reply to an earlier post on Oct 1, 2012, 11:14:04 AM PDT
Did you try to install the certs from http://www.verisign.com/support/roots.html in your browser?
For me it worked perfectly.

Posted on Oct 3, 2012, 11:57:41 PM PDT
BCReview says:
Can't get Kindle for PC to run on one of my Windows netbooks (Windows XP Home SP3). It works on my Windows 7 netbook. I have installed the latest version (twice, today), uninstalled, cold rebooted, reinstalled, a couple of times. I have gone to the 'program files' folder and tried to run directly from there. I have gone directly to one of the free 'content' books the software downloads and tried that.
Nadda, nothing.
My user id had full admin rights.
Any clues?
I downloaded a fresh version yesterday on to my Windows 7 netbook that works (as the existing install seemed to have stopped working).
I really want it on this netbook as it is permanently hooked up to a large portrait-orientated monitor which is excellent for reading.

Posted on Oct 10, 2012, 12:29:52 PM PDT
Last edited by the author on Oct 14, 2012, 4:36:45 PM PDT
IV says:
I have to jump on board with the rest of the frustrated users. I have a Windows 7 laptop and just did a fresh install with the most recent software available on Amazon. No luck. This laptop never had the Kindle for PC app installed on it previously. The program does not open when I double click the desktop shortcut or the executable in the install directory. Very disappointing.

The developers have to know this is an issue. I am very surprised a resolution has not been found or posted in the forum.

UPDATE:
My problem occured on my corporate laptop that was connected to the internet via a 4G Verizon card. When starting the Kindle App I never got the popup that wants your Amazon Account info. (email and password). When I got home, I installed the Kindle4PC app on my personal laptop with no problems. I then proceeded to start the program on my corporate laptop again and sure enough, the Amazon Account Info screen popped up and I was able to use the Kindel4PC application. The only difference was my corporate laptop was now connected to my home network, not the 4G card.

Posted on Oct 10, 2012, 12:46:09 PM PDT
MEH says:
I have now been unable to use Kindle for PC for months. It doesn't look as if Amazon are interested in the problem. Please could someone explain how to install the certificates - I have downloaded them but don't know what to do next ...

In reply to an earlier post on Oct 10, 2012, 7:07:54 PM PDT
gb623 says:
worked great, thanks

In reply to an earlier post on Oct 10, 2012, 7:24:55 PM PDT
I presume you had the older version closed? I haven't used kpc for so long, but its time is coming:-)

In reply to an earlier post on Oct 13, 2012, 4:38:47 AM PDT
Yep. I've been having the same problem now for 3 months. I've tried everything...everything...and nothing works. So frustrating as I'd been using this to organise my "library" of ebooks. I've really just given up on this now. Looks like the Amazon techs just don't care. I'm going to move everything onto Calibre now. At least I'll be able to sort out my stuff then move blocks of like stuff in and out of the Kindle (I think!). It's a real shame that Amazon has decided to ignore this very serious and annoying problem.

Posted on Oct 14, 2012, 5:19:59 AM PDT
In this whole interminable discussion on getting the Kindle for PC to open, I don't think anyone's mentioned using Amazon's Cloud Reader to read their Kindle books. I think Amazon wants to phase out the Kindle software and move everyone and their Kindle books to the Cloud. The software is obviously not a priority, and I believe that's the reason. I think that the Cloud Reader has all the features of the software -- you can underscore, leave notes and search. You're supposed to be able to open individual Kindle books in the Cloud when you're offline, which would, I think would make it functionally identical to the Kindle software. No?
My problem, however, is reading the books offline, because you have to enable your browser for this feature. Despite the fact I think I followed Amazon's instructions to enable Firefox to do this, I still can't read Cloud books offline. Still, going this route might work better for people - if they can get download their Kindle books from the Cloud, to, i.e. enable Cloud when they are off-line. Any thoughts?

Posted on Oct 15, 2012, 2:12:08 AM PDT
BCReview says:
At the moment I'm in Africa and I want to be able to read my Kindle books which I have bought and paid for often at greater price than the actual books offline! Internet access can be patchy and reading books over the net very expensive. I have no idea whether I can enable my browser to read the cloud and I don't trust it.
I took the decision a while back to organize all my ebooks using Calibre when this problem showed up. However, not all ebooks can be organized via it because of DRM which needs Kindle.
I do wish Amazon would take this problem seriously.
No, I don't want to buy an actual kindle because when they refused to offer them outside the US, I bought a different and more flexible ereader.
PS I cannot even get kindle to OPEN on the particular computer, let alone get to registration or anything.

Posted on Oct 23, 2012, 3:02:34 AM PDT
Last edited by the author on Nov 2, 2012, 5:18:50 AM PDT
D. Mueller says:
My Kindle for PC stopped working. I tried downloading the new software and installing it. It did not work. I just spent well over an hour working with a guy on Amazon's chat service. He went round and round in circles. I don't think he read a single thing I wrote. He was just following the decision tree. I requested that I be escalated to the most senior person in his department, he never responded to that request. Folks, Amazon is a joke of a company. Amazon is out to screw the customer.

Update:
I was promised by Sukanya of the online chat help that someone would look into this issue for me and get back to me. That was October 23rd. Today is the 2nd of November. I'm still waiting. But I'm keeping my expectations ankle deep. Amazon is a poor and shabby business. They put out a scrofulous product and don't do a thing to support it. Shame on Amazon.

Posted on Oct 23, 2012, 4:12:56 AM PDT
BCReview says:
After someone mentioned the Cloud up above, I did install it in a browser and have been reading a couple of books that way and it works fine. You can download them to the browser for offline reading so that is better than I thought. The Cloud version though doesn't allow you to 'search' books, but small price to pay to have access to my paid for books on a different computer!

Posted on Oct 27, 2012, 10:46:03 PM PDT
RMH says:
I uninstalled the old version and installed the latest with no luck. After reading through some of these posts I reinstalled the new version again and it works fine.

In reply to an earlier post on Oct 29, 2012, 2:48:27 PM PDT
Last edited by the author on Oct 29, 2012, 2:51:00 PM PDT
ASPPAgal says:
Thank you to Chew&Digest Books for your excellent advice. I did what you said and didn't lose any books/settings. You saved me a lot of frustration and time.

In reply to an earlier post on Nov 2, 2012, 10:07:37 PM PDT
Funny/peculiar. Mine did the same thing just today. Haven't used it for a while. One would think that at least some expiration explanation message would pop up saying it was time to get a new one.

In reply to an earlier post on Nov 7, 2012, 8:46:06 PM PST
I had the same on EeePC but it works fine now. reinstall new version over the old - no need to unistall or reboot. Try and good luck

In reply to an earlier post on Nov 8, 2012, 3:46:41 AM PST
John Homer says:
I also thank you for this quick and easy fix.

Posted on Nov 11, 2012, 1:11:40 AM PST
Rather poor form to simply make the software not work, and cause your customers to chase their tails, thinking something is amiss with their machine; instead of informing the user what is transpiring. Rude!

'Twould be easy enough to pop a dialog box with a message to the effect, could even be kind enough to provide a link for downing the new version.

Thanks to google & this thread, I downed and updated on my XPsp3 machine w/no further issues, and no hoops jumped through.

Posted on Nov 11, 2012, 1:32:44 AM PST
Irish mist says:
me too
been re-booting like a demented idiot thinking it was me (as usual)
er...where do i out the first link of http://www.amazon.com/kindle please
and yes i am clueless - aorry, but grateful for helpful reply

Posted on Nov 12, 2012, 10:13:14 AM PST
Last edited by the author on Nov 12, 2012, 10:15:05 AM PST
Robert, try this:

http://www.amazon.com/gp/feature.html/?docId=1000493771

In reply to an earlier post on Nov 13, 2012, 6:13:11 AM PST
Irish mist says:
shakti speaking - rob out and about and it is me being the useless one on the pc
thanks for reply adrian
when he get back we will have a look and try - sorry - must still mention where do you stick it?
very clueless, sorry

Posted on Nov 15, 2012, 8:27:36 PM PST
D. Horvat says:
OK, just FWIW... I just downloaded the latest K4PC over the existing version that was not working. (XP SP3) Initial dblclk on Icon produced hourglass for a few seconds then nothing, I was watching the action in Task Manager, Processes, and it showed up. CPU and Memory starting counting, stopped and the app went away. Tried again and everything worked great. At this point it looks like you have to try it a couple of times before it works but at least it loads and runs. Can't figure that one out. Thought I had a process stopping the app for some reason, but can't find anything that would make it start and then abruptly just quit running. Anyone else having this problem with the app just stopping?

Posted on Nov 17, 2012, 6:18:11 AM PST
sleeksheep says:
Been having this problem for three months on the PC ( laptop worked all through the upgrades ) , narrowed the problem down to a dll. clash - but couldnt find the culprit.

I used Revo Uninstaller - go advanced ( deep registry scan ) and I deleted all the registry items / folders , everything ( even deleted all my library 1340 books - backed it up to another drive)
Reinstalled K4PC and it back to normal for the first time since August. ( Vista )

Posted on Nov 17, 2012, 2:06:54 PM PST
MJ says:
Also same problem, eventually sat down this evening and was determined to get it sorted out once and for all. I uninstalled the previous version but was unable to download the new version (for Windows 7). I changed browsers and used Firefox instead of Internet Explorer. Then went to FileHippo.com and managed to download and install the Kindle for PC app. All good. Hope this helps someone.

In reply to an earlier post on Nov 18, 2012, 3:22:46 AM PST
Irish mist says:
thank you helpful mj
does it get rid of books and samples too?
will it affect my kindle fire connected, of course, do not want more hoo-hah to sort out

In reply to an earlier post on Nov 24, 2012, 5:58:08 AM PST
Irish mist says:
this sounds hopeful - sorry tardiness from here to all helpful bods
would be very grateful if you send the tips
i am very good about doing email sorting BUT frantically snowed under with 'things to do and not really wanting to but....' and will devote proper and polite attention after 5th december when free to do the things i want to do as soon as possible for my personal delight and delectation!
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Older Kindle Fire Slow to Charge 9 4 minutes ago
Freebie Books - Links Only - No Self Promotion IV 9751 11 minutes ago
Internal storage maxing out when it shouldn't 90 14 minutes ago
kindle reader for ios now displays time of day -- how can I turn this off? 2 30 minutes ago
does Fire stick work on older HD TV's? 210 32 minutes ago
We're Quirky! There Are Various Critters, Including Tail-less Manx Kittens, Here. We Also Have Hugh Manatee. Bring Your Quilting And Sewing Projects, Your Camera, And Your Instant Pot. So Geese And Tally Ho! 3034 58 minutes ago
Discounted / Price Dropped Kindle eBooks IV 2366 1 hour ago
Low internal storage space on Kindle Fire 645 1 hour ago
Kindle won't connect to WiFi - "authentication failed" 103 1 hour ago
No keyboard on Kindle Fire HD??? 74 1 hour ago
 

This discussion

Discussion in:  Kindle forum
Participants:  123
Total posts:  182
Initial post:  Jul 24, 2012
Latest post:  29 days ago

New! Receive e-mail when new posts are made.
Tracked by 35 customers