Hill Climb Racing 2 Industrial Deals Beauty Most Anticipated Fall Children's Books Shop new men's suiting nav_sap_plcc_ascpsc Learn more about Amazon Music Unlimited Get 10% cashback on thousands of musical instruments with your Amazon.com Store Credit Card Starting at $39.99 Grocery Handmade Tote Bags Home Gift Guide Off to College Home Gift Guide Book a house cleaner for 2 or more hours on Amazon Transparent Transparent Transparent  Introducing Echo Show Introducing All-New Fire HD 10 with Alexa hands-free $149.99 Kindle Oasis, unlike any Kindle you've ever held GNO Shop Now STEMClubToys17_gno
Customer Discussions > Kindle forum

Kindle Fire cannot connect to internet


Sort: Oldest first | Newest first
Showing 176-200 of 849 posts in this discussion
Posted on Dec 5, 2011, 10:57:35 AM PST
J. Johnson says:
Since the day I bought mine it has had this problem. I can connect fine to my network and I'll be browsing the web. After a few pages (maybe 5-10), it just won't load anything. I disconnect and reconnect wifi and it won't reconnect until I stop the browser. Annoying as hell and that along with the jumpy video will probably force me to send it back.

In reply to an earlier post on Dec 5, 2011, 11:00:42 AM PST
LarryB says:
I just sent an email to Amazon customer support and will report back what I hear.

Posted on Dec 5, 2011, 11:14:39 AM PST
Jeanne says:
Is anyone having a AC charging problem with their Kindle Fire?

Posted on Dec 5, 2011, 3:38:06 PM PST
emcrumb says:
I too have suffered from the "cannot connect to WiFi" and the eternal hellish cycle of "obtaining IP address". Two calls to customer service failed to resolve the problem. The first one had the audicity to tell me that the 6.1 download will require a USB cable that is "an additional purchase"....the hell it is! If it's a required piece of equipment, it should have shipped with the product. I emailed off my log as instructed, someone was supposed to FOR SURE call/email me back with a fix and I'm still waiting. I rebooted the router and the Kindle Fire device several times, have now downloaded the 6.1 upgrade, none solved the problem. All other devices work just fine with our WiFi in the house. Yeah, well, it doesn't matter now, it's going back to Amazon. At this point, the customer service (or lack thereof) and the product have completely soured the experience.

Posted on Dec 5, 2011, 3:43:36 PM PST
Last edited by the author on Dec 5, 2011, 3:44:22 PM PST
Heartzincali says:
No worries with internet access from either my home or office. I just received this beauty on Sunday. Setup for WIFI was great for both locations.

Posted on Dec 5, 2011, 3:48:32 PM PST
Kathy Nelson says:
My Kindle Fire has had
problems since the first day. I've
Done all the updates and powering it
Down which doesn't help.
I can't get it to stay on. It freezes
Up continually. I'm
Probably going to take it back. Sad!

Posted on Dec 5, 2011, 6:27:20 PM PST
My Kindle Fire was fine yesterday. Showed to need to be charged. Plugged it up but it will now turn back on. Have had it charging all day. Was loving it, but don't know about that now. Anyone else having the same problem as mine?

Posted on Dec 6, 2011, 10:52:31 AM PST
Last edited by the author on Dec 6, 2011, 10:53:32 AM PST
Doug J. says:
No problems with WiFi on my LAN and the Internet, or anything els, right out of the box. I have since upgraded to 6.1 and 6.2 but I haven't had time to experiment much to see what has changed.

In reply to an earlier post on Dec 6, 2011, 10:54:28 AM PST
Doug J. says:
Not me.

Posted on Dec 6, 2011, 10:55:43 AM PST
I just set up a second Kindle Fire on my home network and it works as flawlessly as the first.

In reply to an earlier post on Dec 6, 2011, 12:29:25 PM PST
Doug J. says:
No charging problem here.

In reply to an earlier post on Dec 6, 2011, 12:30:29 PM PST
Last edited by the author on Dec 12, 2011, 6:30:46 AM PST
I have a suspicion the Fire will connect to newer routers without any trouble but older wireless networks are inconsistent at best. My home network is over 4 years old and connects perfectly with my notebook, iphone, and my friend's notebooks and Iphones. The Fire connects intermittently for a few hours and then disconnects and will not connect again for days. It does not connect on my business network with WEP security (another network router over 5 yrs old) but picks up unsecured networks in the area. I am upgrading my router and will post the results.
UPDATE After switching out my router to a DLink DIR-655 the Fire connected immediately and has remained connected for 3 days without any issues. This router has a much stronger signal then the older Linksys.

In reply to an earlier post on Dec 6, 2011, 6:08:16 PM PST
Dale G says:
my fire works great, on and off wi-fi. i guess it compares to this example:: if your neighbor loses his job, it is a recession, if you lose your job, it is a depression. relate this to your fire, you are in a depression state of mind.........

Posted on Dec 6, 2011, 6:21:27 PM PST
My home wifi connection works fine, but at a pub I experienced the same problems reported by others-i.e., Kindle showed wifi signal but couldn't connect, and a small "x" appeared by the icon. An hour of frustration ensued. I will try the update-and hope that amazon takes note of this situation!

Posted on Dec 6, 2011, 7:09:15 PM PST
Doug J. says:
I wonder if the reason I don't have any wifi problems is because I am running an open router.

In reply to an earlier post on Dec 7, 2011, 12:46:50 AM PST
I really don't think it is an issue with the age of the router. My Fire connected fine at home and at most hotspots. However, at one or two hotspots, it would not connect. One day it DID connect with no problem and never worked at that location again. However, it worked everywhere else including home. Must be internal workings of the Fire.

Posted on Dec 7, 2011, 11:32:29 AM PST
M. Poe says:
I never had any problems until after the update to 6.2. Rebooting the router seems to have worked though. Thanks everyone!

In reply to an earlier post on Dec 7, 2011, 6:10:56 PM PST
sandy w says:
How do you update t 6.1?

In reply to an earlier post on Dec 8, 2011, 1:19:31 PM PST
Amell says:
Just got my KF yesterday an dhave the wifi problem - "x" next to Wifi logo and no internet access, even though it says connected to network. I spent over an hour last night with customer service, who said they had not heard of this issue (right!). Tried everything, several reboots aand upgrading software to 6.2, also resetting to factory default. It works for a while, then the dreaded "x" returns. They had me email them the device logs, but I haven't heard back. I'm returning this and sticking to my iPad!

In reply to an earlier post on Dec 8, 2011, 1:28:36 PM PST
Amell says:
I have a fairly new Cisco "N" router, and still am having the problem of no internet access, and the "x" next to the WiFi logo

In reply to an earlier post on Dec 8, 2011, 9:11:48 PM PST
H. Youssef says:
We had this same problem (connect to wifi but no internet) and we fixed it by using "Static IP Settings" Under Wi-Fi, Advanced Settings. You give your kindle a static IP Address therefore avoiding any DHCP issues and the "x" goes away.

In reply to an earlier post on Dec 8, 2011, 9:20:13 PM PST
Vicki L says:
Amell, try resetting your router back to the factory default settings. That fixed the "x" problem for us.

Posted on Dec 8, 2011, 10:00:28 PM PST
Karlo Plata says:
I had the same issue with my Kindle fire. I am ABLE to connect to the router but UNABLE to get an internet connection. All other gadgets i have at home (macbook, iPhone, etc.) can connect to the router AND internet at home but my KF. If you have a 4G connection at home like me, maybe you can try this to make your KF work:
1. Check if your Ethernet cable (the cable you use to connect the modem to the router) is connected using the WAN port. If not, then you should. I found out that even if you connect the ethernet cable to any of the the LAN ports of the router, you'll be able to use the router for internet using other gadgets but not KF. This makes it hard to discover why KF is not able to connect to the internet in the first place.
2. Once ethernet cable is connected to the WAN port, check if your router has the same IP address as your 4G modem - if they are the same, then you'll have trouble using your 4G connection. Change your router IP address using factory instructions(more on this later). I have a TP-Link 3G/3.75G Wireless N Router and I access the router configuration menu by connecting my router (via any one of the LAN ports) to my ethernet port of your PC, then opening a web browser and entering http://192.168.1.1. (This is normally the default address of most routers)
3. Changing your router's IP address is simple but can be quite tricky. For me, I changed it to 192.168.2.1 (notice I changed 1 to 2 from my default IP address?). Just make sure that DHCP is set to Enabled. This is important for non-techies because if DHCP is disabled, you will need to manually enter an IP address for ALL gadgets you need to connect to the router.
Let me know how it works for you. I claim no expertise in this field, all my information I got for spending a good 4 hours figuring this out so I wanted to share it to other KF users who are non-techie like me.

Posted on Dec 10, 2011, 5:18:56 PM PST
J. Sweet says:
I am having these same issues connecting to the internet or staying connected as well. Also when listening to music that has been downloaded it will stop playing before songs have finished playing. Anyone else having issues with playing music?

Posted on Dec 10, 2011, 5:49:49 PM PST
SPR says:
From the outset, the KF connected to my WIFI, but no internet access. After an hour and a half with 2 different tech support people and a version update, I still have the same problem. Like others, I emailed a log to support and was told I would have a response in a few days to a week. This is my first bad experience with Amazon. I am a very patient person, but with the magnitude of this problem, I am very concerned this might not have a happy ending.
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

 

This discussion

Discussion in:  Kindle forum
Participants:  483
Total posts:  849
Initial post:  Nov 15, 2011
Latest post:  Jul 30, 2017

New! Receive e-mail when new posts are made.
Tracked by 90 customers