Industrial Deals Beauty Best Books of the Year So Far STEM nav_sap_plcc_ascpsc Starting at $39.99 Wickedly Prime Handmade Wedding Shop Book House Cleaning _fof _fof _fof  Introducing Echo Show All-New Fire HD 8 Kids Edition, starting at $129.99 Kindle Oasis Trade it in. Fund the next. Shop Now toystl17_gno
Customer Discussions > Kindle forum

Kindle touch dictionary


Sort: Oldest first | Newest first
Showing 1-23 of 23 posts in this discussion
Initial post: Dec 6, 2011, 2:14:40 PM PST
C. Settle says:
I see a lot of people having trouble with dictionaries in other languages, but my problem is that when I try to look up a word, I get the message, "There are no dictionaries on your device." There are two dictionaries on my device, and I can use them both, but neither of them will come up when I try to look up a word in a book. Anyone else have this issue??

Posted on Dec 6, 2011, 2:22:55 PM PST
FranB says:
I've not used the Touch, but my K3 and Fire both look up words for me. I'd contact CS. Perhaps a setting needs to be changed.

Posted on Dec 6, 2011, 4:00:48 PM PST
B. Gonzalez says:
I wonder if it just doesn't have one of them installed as the default dictionary. Try going Menu - Settings - Dictionaries and see what it says. Mine says English The New Oxford American Dictionary.

Good luck!

Posted on Dec 6, 2011, 4:15:00 PM PST
C. Settle says:
Mine says the same thing, but then when I try to use it while reading a book, it says that there are no dictionaries on my device.

Posted on Dec 7, 2011, 7:50:03 AM PST
B. Gonzalez says:
Since I like to hack, I would delete it from my Kindle, do a reset and then resend it from my library and make sure it is set as the default...and if that didn't work I would MAYBE call Kindle CS. However, you should know that I don't ask for directions when lost either!

In reply to an earlier post on Dec 7, 2011, 8:36:49 AM PST
C. Settle says:
Thanks for the advice...I'll give that a try.

Posted on Dec 7, 2011, 8:40:06 AM PST
C. Settle says:
Once I put one dictionary (there were two on it automatically) into Archives, the other automatically became the default dictionary. Thanks for your help!

Posted on Dec 7, 2011, 9:24:45 AM PST
B. Gonzalez says:
It worked? Great! Glad to have been of help.

In reply to an earlier post on Jan 1, 2012, 5:45:56 AM PST
Martin Kriz says:
Yes, that's what I did and now it works. Thank you. There were two Oxford dictionaries - American English & just English. I moved the American to the "Archived items" and now I just tap a word and a definition pops up. But how should I know in the first place - has it to be done with all Kindle Touch's?

Beside this clumsiness, the Touch seems to be a great device. It also took me a while to discover that what I considered a speaker was in fact a home button :)

I love the classic books collection freely available for download. It has about 4500 pieces, inluding the best books ever written and the device's memory is getting fuller and fuller.

In reply to an earlier post on Jan 7, 2012, 5:35:57 PM PST
[Deleted by the author on Jan 7, 2012, 5:37:39 PM PST]

In reply to an earlier post on Jan 7, 2012, 5:42:08 PM PST
Craig Evans says:
Dictionary definitions don't appear on Kindle Touch. We had the exact same problem. The fix was so simple. We just did a hard reset (or whatever it's called). It doesn't change or delete any books or settings, but it clears the problem. Here's how:

Press and hold the power button for 20 seconds. Restart the Kindle Touch. That's all there was to fixing ours. ~ROD

In reply to an earlier post on Jan 10, 2012, 3:53:13 PM PST
Tai says:
Thanks for your post! I just ran into this problem this morning on my touch. The touch said there were no dictionaries installed when clearly there were two on the device.

I thought I had reset the device by holding down the button until the screen went blank, but I guess that just turns it off. Holding it down for the 20 seconds did the trick.

Posted on Mar 17, 2012, 12:06:27 AM PDT
Willy-in-VT says:
I completely lost use of my OED. It shows in the archives, it will not open and I cannot move it to any other directory. I used to be able to see it listed as one of my two dictionaries to chose from in the settings menu. I have tried to restore OED so many times I have lost count. I would like to try moving the OAD into archives to see if that enables me to use OED, but I am afraid of losing OAD, which is my price reference. Amazon told me the OED had a formatting issue which is why I could not get it to load properly. That was two weeks ago.

In reply to an earlier post on Apr 27, 2012, 1:33:09 AM PDT
the same thing happens to me, when i highlight a word, after have set my default dictionary, kindle says that there isn't any dictionary for language selected! It's impossible, I hope this bug will be patched as soon as possible because it's very frustrating.

Posted on Apr 27, 2012, 2:03:36 AM PDT
CBRetriever says:
just archive it and then redownload it or else apply the update and get all the new dictionaries as well

In reply to an earlier post on Apr 27, 2012, 4:41:04 AM PDT
I'm sorry but i've tried it again, i put old dictionary in "archived items" and start to download a new one, but the result is the same.
I'm at 5.1.0 firmware version. When i touch to highlight a word i obtain the following error: "Dictionary not found" ... "The device does not contain the dictionary for book language ...". I have seen in the root kindle folder and i have found under /kindle/documents the The New Oxford American Dictionary_B0053VMNY2.azw and the corrisponding directory with the same name. Any solution is well accepted. Thank you

Posted on Apr 27, 2012, 4:43:34 AM PDT
CBRetriever says:
Have you done the reset/restart as described above?

In reply to an earlier post on Apr 27, 2012, 5:57:14 AM PDT
hi again, i have previously downloaded English/american dictionaires, so they are on my kindle, then i power off kindle for 20 sec as told.
After i restarted it, tapping on the first book in english that i have in my collection, highlight the first word and obtain the same result. " The device does not contain the dictionary for book language ...". I put at last the dictionaires that are anyway present in my kindle in archived items and download it again ... do you see something wrong in this procedure or something that i have shipped ?

Posted on Apr 27, 2012, 6:13:34 AM PDT
I have solved, i believe that the problem was bound with .epub format, so i converted in .mobi and now works fine. Unbelievable :)

Posted on Apr 27, 2012, 6:22:29 AM PDT
CBRetriever says:
good, glad to hear you resolved your problem

Posted on Jul 27, 2012, 6:56:22 AM PDT
Reset (hold power for 20 seconds) did the trick for me.

Posted on Sep 30, 2012, 5:31:38 PM PDT
Jack R says:
The 20 second reset worked just fine for me too. Thanks for sharing that!

In reply to an earlier post on Nov 28, 2012, 11:49:39 AM PST
Last edited by the author on Nov 28, 2012, 11:50:05 AM PST
Tenley says:
Archiving one dictionary so I only had one active not 2 worked for me too, thanks!
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Unable to Setup Yahoo E-mail on Kindle Fire HD 45 31 seconds ago
Amazon Echo (Part 2) 570 36 seconds ago
We're Quirky! There Are Various Critters, Including Tail-less Manx Kittens, Here. We Also Have Hugh Manatee. Bring Your Quilting And Sewing Projects, Your Camera, And Your Instant Pot. So Geese And Tally Ho! 2314 4 minutes ago
Amazon Echo (Alexa) bass and treble settings 1 12 minutes ago
Page Numbers of Actual Book 15 17 minutes ago
87th RAOK Let the winter fun begin! 9529 19 minutes ago
How do you edit an email contact on the Kindle Fire? 13 28 minutes ago
SwagBucks Thread 2016 2268 29 minutes ago
KINDLE KITCHEN #6: A place for sharing, caring, chat and FUN! 7788 30 minutes ago
Dragi's Croatian Crab Shack and Wine Bar - The Answers Are Blowing In The Wind 5544 34 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  12
Total posts:  23
Initial post:  Dec 6, 2011
Latest post:  Nov 28, 2012

New! Receive e-mail when new posts are made.
Tracked by 4 customers