Amazon Vehicles Buy 2 kids' books and save Amazon Fashion Learn more nav_sap_plcc_ascpsc $5 Albums Fire TV Stick Health, Household and Grocery Back to School Totes Summer-Event-Garden Amazon Cash Back Offer TheKicks TheKicks TheKicks  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis Celine Dion Shop Now STEM
Customer Discussions > Kindle forum

Kindle Fire - How to change WIFI security type?


Sort: Oldest first | Newest first
Showing 1-13 of 13 posts in this discussion
Initial post: Aug 19, 2013 3:34:29 PM PDT
Miamicuse says:
I have a Kindle Fire and previously had configured to access my home WIFI network. I configured my Kindle to work with that and it has been working fine.

Due to some recent hardware changes I needed to change my WIFI from WEP to WPA2.

I changed all my notebooks, printers, iPad, phones etc...and all worked except I couldn't figure out how to reconfigure the Kindle to do this.

At first I thought I just need to change the properties of my network on the Kindle, well there is no way as far as I can tell to change any of the properties except for the password.

Next I thought may be I just need to "FORGET" the network altogether and create a new one with the same name and go through the steps, only I can't seem to FORGET my network. When I tap it the screen prompting for password comes up and there is only a CANCEL button but no FORGET.

I turned off the router altogether and still Kindle wouldn't let me get rid of that network.

I hope I don't have to end up renaming my network ID simply to get around this problem.

Any ideas?

In reply to an earlier post on Aug 19, 2013 3:44:11 PM PDT
A. Dietz says:
To forget the network, long-press the network name, don't just tap on it. A pop-up box will have "forget" as one of the options.

Posted on Aug 19, 2013 4:00:47 PM PDT
Miamicuse says:
Thanks.

I tried the long press. It activates the same pop up screen as a simple tap. In fact, I just went through several durations of presses from 1 sec to 5 sec, no difference. They all bring up the same screen. Is it possible there is some sort of press/mouse timing setting that controls this?

Posted on Aug 19, 2013 4:06:59 PM PDT
Artist says:
Have you tried just entering your password when the box pops up to and see what happens? Since it's asking for the password, perhaps it has picked up that you have a "new" router.

Posted on Aug 19, 2013 4:32:07 PM PDT
Miamicuse says:
I did, it didn't work, "Error In Connection". The popup screen still shows the security type = WEP which is no longer the case.

In reply to an earlier post on Aug 19, 2013 4:37:20 PM PDT
Did you reboot the Fire?

Posted on Aug 19, 2013 4:44:27 PM PDT
Miamicuse says:
Yes, rebooted, as well as turned OFF Wireless Networking and turned back ON. I also tried turning off my wireless router so it won't be able to scan it. Still no luck.

In reply to an earlier post on Aug 19, 2013 4:46:22 PM PDT
Artist says:
Have you asked customer service?

Posted on Aug 19, 2013 4:55:29 PM PDT
Tony says:
Turn the router off and now hold the KFHD button for 30 seconds. In this time, the tablet will power off. Now turn it back on. This is a soft reboot. Now turn your router on and let it become fully active. Now try to add your network to the KFHD.

If it does not add your network, you may need to do a hard reboot. The KFHD itself will adapt to what ever security your modem uses. Your modem is your firewall for wireless items. It's not something you adjust within the tablet. Good luck.

Posted on Aug 19, 2013 5:16:10 PM PDT
Miamicuse says:
Tried that and it didn't work. Still pops up and say it's WEP. I had every other devices configured without any issue except the Kindle Fire. In fact, my sister's B&W old Kindle worked without any problem when I tried to reset it, as I was able to add a new network with a security type of WPA2-PSK.

On my Kindle Fire, it won't work. I even turned off my router, and while it's OFF, created a new network with same name, selected the proper security type and password. Then I power up the router again, wait till it was up and running, and then I saw two network with same name showing on the list, and after a few seconds, one of them went away, the other one that's left, when I clicked on it, says WEP. No luck.

Tried this with the router on, router off, router rebooted, Kindle rebooted, all permutations I can think of.

I am thinking the only way is to connect to a computer via a USB and I can browse it's system directory somehow and find the configuration file for the wireless network to either modify it manually or delete it altogether.

Posted on Aug 19, 2013 5:32:04 PM PDT
Last edited by the author on Aug 19, 2013 5:35:51 PM PDT
Tony says:
Try this - Go to your home screen go to settings > more > wireless network group > add a network. Now tap on the security options for WPA2 option. This is for the Kindle Fire (thought you had the KFHD, sorry.)

Leave the router on for this. The router is not the issue. I see you tried something similar but this is the way to do it. If it does not work, a hard reset may need to be performed. I would contact customer service first.

Posted on Aug 20, 2013 5:52:42 AM PDT
Miamicuse says:
Thanks ironfist. the steps:

settings > wireless network group > add a network

pulls up a screen for me to add a new network. I have the following prompts:

Network SSID:
Security Type: Open / WEP / WPA PSK / WPA2 PSK / WPA EAP / WPA2 EAP

I selected WPA2 PSK

then entered the password, then pressed Save.

Once I did that, the new network, which is the same name as one I originally had, both listed on the network list.

Then one of them showing "Connecting..." and a few seconds, one of them disappeared. I am left with the same network name, if I tapped on it, it comes up and I see security type = WEP.

It seems to be convinced my network is WEP when seven other devices all have been changed to work with WPA2 successfully.

I see a bunch of other topics in this forum about Kindle unable to "forget" your primary connection and there is no solution posted, they all end up unresolved.

Posted on Jul 16, 2014 5:27:53 AM PDT
Hi Miamicuse
I am having exactly the same problem has you had with your kindle! Did you ever get this resolved? If you did, please could you advise me how to fix this problem?
Thank you
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Needing a replacement kindle screen 99 3 minutes ago
KINDLE KITCHEN #6: A place for sharing, caring, chat and FUN! 131 7 minutes ago
We're Quirky And We Know It! Come Witness The Howling Dink, Hussy Turkey Hens, And A Veritable Plethora Of Other Beasts! So Geese! 5762 8 minutes ago
Potentially Perky People - Part Deux 7916 14 minutes ago
Can you connect a flash drive to Kindle Fire HD using an adapter? 61 16 minutes ago
86th RAoK - Let the Games Begin 4422 19 minutes ago
I was deleting books from my cloud & I delete my Jimmy Swagger bible. Is there any way I can get it backk 144 21 minutes ago
How to use VUDU cloud movies on kindle fire HD 7 in 276 23 minutes ago
VPN on a Kindle Fire 87 36 minutes ago
Free Books and Chat - August 2016 770 42 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  6
Total posts:  13
Initial post:  Aug 19, 2013
Latest post:  Jul 16, 2014

New! Receive e-mail when new posts are made.
Tracked by 4 customers

Search Customer Discussions