Bubble Witch Saga 3 Industrial Deals Beauty Best Books of the Month STEM nav_sap_hiltonhonors_launch New Album by Big & Rich GNO for iPhone 8 Starting at $39.99 Grocery Handmade Tote Bags Home Gift Guide Off to College Home Gift Guide Book a house cleaner for 2 or more hours on Amazon BradsStatus BradsStatus BradsStatus  Introducing Echo Show Introducing All-New Fire HD 10 with Alexa hands-free $149.99 Kindle Oasis, unlike any Kindle you've ever held Tailgating PSFF17_gno
Customer Discussions > Kindle forum

Kindle fire help needed - email not working

Sort: Oldest first | Newest first
Showing 1-22 of 22 posts in this discussion
Initial post: Feb 17, 2012, 6:27:05 AM PST
Good morning, All,

I need some assistance with my new Kindle Fire. The email app was working at first, now it gives me an error message and will not open any emails. Not sure what is going on with this. I sure wish this thing had come with some kind of manual instead of that skimpy thing installed on it.

Hope someone can help me out,

In reply to an earlier post on Feb 17, 2012, 6:30:16 AM PST
Sandy - Try resetting your email App.
On your Home page:
* Settings (gear icon) > More...> Applications
* Set filter to "All Applications"
* Swipe down to the Email App
* "Clear Data"

In reply to an earlier post on Feb 17, 2012, 10:01:22 AM PST
I tried this and got as far as resetting the email and the kindle is looking for my server. Didn't encounter this the first time around but now I get an error message that says: "Setup could not finish. Cannot connect to server. (Unable to connect)." My laptop and iphone are finding the wifi perfectly fine. Everyone else's electronics that need the server are fine but mine.

In reply to an earlier post on Feb 22, 2012, 6:30:29 AM PST
I am having same problem. I keep deleting my hotmail and gmail accounts, and re-entering and it works fine but after 15 minutes it gives me failure to retrieve email messages

Posted on Feb 23, 2012, 10:44:44 AM PST
A call to Amazon Customer Service referred me to my cable provider (where my email originates). Between the two of them they reset the outgoing and incoming settings and all is working fine. Amazon Customer Service even called me back to make sure all was working great.

Posted on Dec 9, 2013, 10:15:37 AM PST
Evelyn Marcy says:
I received very good help when I could not retrieve and e- Evelyn ail-got it solved without any further problem. EVvelyn M

Posted on Dec 9, 2013, 10:45:28 AM PST
ILoveGadgets says:
I think I know what the problem is when it comes to gmail. It has to do with the IPV6 settings that our ISPs are using and the fact that Google requires certain settings to be able to 'talk' to gmail. I had to turn off my WAN IPV6 dynamic dhcp. I hated to do that but it did fix the problem immediately. Unfortunately that is only a band aid and not a long term acceptable fix. I have a different, more aggravating problem right now and that is that my HDX won't maintain an active wi-fi connection. I am getting so frustrated that I may return it.

Posted on Dec 9, 2013, 10:54:26 AM PST
L. Hill says:
ILove - just to verify - this email thread is old...
GMail on HDX - I had no issues...didn't mess with either V4 or V6 settings...
Maintaining active wifi - is that for ANY location, or only one? IE - is it happening when you are out and about, or only on home wifi? It could be your router...maybe a reset on that might help? There have been issues in the past with older routers having limits on number of devices it would support...just a thought...

In reply to an earlier post on Dec 9, 2013, 10:57:38 AM PST
ILoveGadgets says:
Hi, I didn't notice this was an old thread. It worked the 1st day and then wouldn't connect. It was Amazon's team that came back with the root cause being my ISPs IPV6 'method' and Google's gmail settings. I researched it and reached out to my ISP after I checked the router and found that the WAN dynamic dhcp for IPV6 was enabled. On the phone together we disabled it and my gmail server connection immediately started working. This is not an old router. I reset it a few times before having to do this. I do work in IT so tend to do all the low hanging fruit items first.

In reply to an earlier post on Dec 9, 2013, 10:58:31 AM PST
ILoveGadgets says:
Oh, and the constant dropping of the wifi on the HDX - I found several other people posting to another thread with the same issue. It is limited to my HDX and neither of my Kindle Fire HD's.

Posted on Dec 9, 2013, 11:39:36 AM PST
L. Hill says:
Aha...thanks - wasn't trying to be simplistic - but some don't think of that issue (reset router). Was wondering about other locations...I have HD and HDX - no problems at home, office, or 3 "free" locations I have tried thus far. Wonder if it is an antenna issue internal? Is it "Contact CS, get a new one" time?
On HD, I was using an email program called "K-9" - to sync to the 5 email accounts I monitor. Now, on HDX, I am using the resident email setup, which looks amazingly like "Google Mail" to me. I had no issues setting up the 5 accounts, ranging from GMail accounts, to free account (inbox.com) to office accounts on our hosted server with work domain. I didn't have to mess with any settings on our routers to hook to any systems...

In reply to an earlier post on Dec 9, 2013, 12:06:40 PM PST
ILoveGadgets says:
I have only been using the native email app on my Kindle's. I love the newest one on the HDX. I did test by disabling the wifi on the HDX and using a cellular connection and the email connected to the server right away which does lend support to the notion that it is how the ISP is handling the IPV6. I did find that Google is requiring certain settings when using IPV6 that supposedly help with spam but they really don't. They are rejecting email from IPV6 addresses with no reverse name and maybe that is why it refuses to connect to gmail. It will sync the contacts and calendars just fine but will not talk to the gmail server at all. My ISP probably won't do anything to help since I figured out a band-aid but I might continue to contact them about it. I am all ears for any suggestions. For grins and giggles, I re-enabled the WAN IPV6 dynamic dhcp. This is really aggravating. All of my other gadgets work just fine. This issue is limited to my Kindle Fire HDX and HD. So far, knock on wood, my Kindle Fire HD 8.9 has been working with gmail in the native email app all along. I even recently retired several tablets to sell and they were all working just fine too. There is something specific going on here and I am all ears as to what to do.

Posted on Dec 9, 2013, 1:16:07 PM PST
L. Hill says:
Could it be your actual HDX device? Know anyone with a new Kindle that can come check for you? Will check at home - but pretty sure I have 4 & 6 enabled...and do know both office and home are dynamic vs. static. Two different ISP's too - ATT T1 at one office, ATT DSL at other, TWC Cable at home. Home router new Asus, Office an old 2Wire ATT modem/router combo. And - like I said - no problems or issues at "free" locations, to include a local coffee shop that issues password daily on your receipt...even traveled this past Thanksgiving, and no problem at hotel or sis-in-law's house - connected right away, no drops of signal. That's why I was asking about other locations - are you able to hook wifi in other locations with your HDX?

When all other avenues are exhausted...go with the simple...it's a hardware "broke" issue...work through Customer Service (almost said "Use the mayday button" - DOH...if you can't hold wifi...ah...you can't "Mayday"). If you have never worked with CS at Amazon - they are really pretty good and easy to work with. Suggest you use the "Call me at this number" function, found under the help/contact info. It really shouldn't be that difficult to hook up - while hardware and OS are changed, it wasn't enough of a change to cause all of this!!! None of this is super-new tech - the HDX is using pretty tried and true stuff, no ground-breaking stuff...

Of concern to me is this Memory issue that seems to be coming up on the 64GB 8.9"HDX...people loading their memory over 40GB+ and then removing some of it are having their Fire's brick...not good! I am wondering (and haven't had time to research it) if there is an issue with this version of Android and large memory stacks...or, if in their "forking" of the raw Android to make "Mojito"...they forked a little too hard...

Posted on Dec 9, 2013, 1:31:33 PM PST
ILoveGadgets says:
I used the Mayday to report the issue to them at the outset and they came back with the IPV6. The weird thing is now that I re-enabled the IPV6 for the WAN on my TWC modem, I am back to not being able to connect to the gmail server. I have worked with them a lot and it does add to the frustration. I hate to get another HDX and find it does the same thing. The issue actually showed up on my Kindle Fire HD too. But not my HD 8.9. Now the server settings on the HD 8.9 are entirely different and I cannot do that same setup on my HDX. Their default method when I got the 8.9 was to use Exchange but you know that Google abandoned that entirely thanks to a 'spat' between them and Microsoft on the protocol use. So that still works but I cannot do the same settings on my HDX. If I could, I would be back in business. Also, when I connect via a cellular network, it works which, at least anecdotally, points to my ISP settings.

Posted on Dec 9, 2013, 1:48:06 PM PST
L. Hill says:
ugh...thankfully, I don't have to worry about Exchange - we're not big enough. Simply using Outlook and native hosted email for office. Makes things easier...even T1 is basic setup, more like a home setup...went T1 for speed as we use several cloud based apps...

In reply to an earlier post on Dec 9, 2013, 1:54:55 PM PST
ILoveGadgets says:
This was the setup that my Kindle Fire defaulted to back when I got it. And it works even though it really shouldn't. I do know they grandfathered in people who had that setup so I suspect that if I remove it, I won't be able to use it again. I may end up with a replacement HDX anyway with the terrible connection issues. It is constantly no longer talking to the wifi even if it shows you it is, it really isn't. Easily demonstrated by any time you try to go to a web page, refresh email, refresh twitter feeds, etc... If you turn off the wifi and turn it back on, it works for a while. This is only happening with the HDX and at least there are several other people reporting the same experience on another discussion. The obvious challenge there is watching for them to post any updates to the OS and manually download since the wireless probably won't stick long enough to get it. When it works, the device is excellent. But these problems have been a real turnoff for a device that I would be a real fan of. I bet if they update the mail app for the 8.9, I will be in the same situation.

Posted on Jan 6, 2014, 12:10:05 PM PST
K says:
In just received a kindle hd . The thing ALWAYS sends.my email s.l.o.w.l.y , over any wi fi, at all location (@ home, work, family house, coffee house) VERY SLOWLY, LATE, SOMETIMES 5 hours late. Hate the stupid spell ck. sending the Damn thing back.

In reply to an earlier post on Jan 6, 2014, 12:45:38 PM PST
MikeJW says:
Thanks for letting us know, K.

Posted on Jan 22, 2014, 2:16:11 PM PST
dolly says:
I'm having the same problem as a lot of you, gmail worked fine when I set it up for the first time. But for months now everytime I try to send an email I get an error message. WTH!

Posted on Feb 9, 2014, 6:07:22 AM PST
lesly says:
All of the sudden my kindle fire can't connect to gmail server

Posted on Jan 30, 2015, 7:40:56 AM PST
Ok I got a Kindle Fire XD. But at first I could open gmail online just fine. Then suddenly I started to get a message that says "Bad Request 400" and ao I showed my mom and she couldn't get a explanation........So I need some help.

In reply to an earlier post on Mar 3, 2017, 9:16:55 AM PST
Perdida says:
I was getting a "connection problem" error after not using my Fire for a month or two. I deleted and reauthorized my Gmail account to no avail. Then I booted down my Fire and restarted it. Everything is working again. Beats me!
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum


This discussion

Discussion in:  Kindle forum
Participants:  12
Total posts:  22
Initial post:  Feb 17, 2012
Latest post:  Mar 3, 2017

New! Receive e-mail when new posts are made.
Tracked by 6 customers