Amazon Vehicles Up to 80 Percent Off Textbooks Amazon Fashion Learn more Discover it Joseph Fire TV Stick Happy Belly Coffee Totes Summer-Event-Garden Amazon Cash Back Offer ElvisandNixon ElvisandNixon ElvisandNixon  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis GNO Shop Now
Customer Discussions > Kindle forum

getting unable to install hardware "mtp device" error message when connection kindle fire to pc


Sort: Oldest first | Newest first
Showing 1-8 of 8 posts in this discussion
Initial post: Oct 17, 2012 4:02:59 PM PDT
i found a solution if anybody is interested be more than happy to share let me know

Posted on Oct 17, 2012 4:10:41 PM PDT
Fud53 says:
Why wouldn't you: 1)say you had the solution in the title? 2)just give the solution without people having to ask?

Posted on Oct 17, 2012 8:10:14 PM PDT
well
1) when i did they deleted my post
2) didnt know there were forum critics out there
3) like i said if you interested i ll be more than happy to help

Posted on Oct 20, 2012 2:05:48 PM PDT
David says:
Ummm, yeah, please share

In reply to an earlier post on Oct 20, 2012 2:37:01 PM PDT
Last edited by the author on Oct 20, 2012 2:38:14 PM PDT
First, the background-

I installed Windows XP onto a laptop, the XP had SP3 & WMP11 integrated on the cd.

I then tried to get my kindle to connect - and ran into the same problem. While installing the driver, it detected the MTP driver, and then the "New Hardware Wizard" popped up and failed with the error:

Code:

There was a problem installing this hardware: MTP Device

An error occurred during the installation of the device.

The filename, directory name, or volume label syntax is incorrect."

I tried a load of different things to try and resolve, Reverting to WMP10, Copying the MTP driver from a working PC etc etc etc to no avail.

The solution, I finally discovered was to do with the UMDF (User Mode Driver Framework) service. It comes with WMP11, and installs during the setup.

Looking at the UDMF installation logs (c:\windows\Wudf01000Inst.log) - I found that there were errors during installation - I figured that re-installing UMDF might fix the problem. (and it did!) Unfortunatly, as it is not in add/remove programs, I ran into problems trying to remove it. If you un-install WMP11, it does not remove the UMDF dll's. If the dll's exist, then the UMDF installer will skip during the re-install of WMP11.

I managed to manually re-install UMDF using the method below.

To find the installer files for UMDF, you need to get them out of the WMP11 Installer.

Code:

How to find the installer for UMDF

1) Run the WMP11 Setup file "wmp11-windowsxp-x86-enu"
(It will extract the installer files into your %TEMP% folder)

2) Click Start -> Run -> %temp%
3) Press F3 and search for "umdf.exe"
4) Copy this file to your Desktop
5) Cancel the WMP11 Setup.

Now, you need to fool windows into thinking that UMDF is not installed on your computer, by renaming some files. Copy & Paste the following into a Command Prompt.

Code:

rename C:\WINDOWS\system32\drivers\wudfrd.sys den_wudfrd.sys
rename C:\WINDOWS\system32\drivers\wudfpf.sys den_wudfpf.sys
rename C:\WINDOWS\system32\wudfhost.exe den_wudfhost.exe
rename C:\WINDOWS\system32\wudfsvc.dll den_wudfsvc.dll
rename C:\WINDOWS\system32\wudfx.dll den_wudfx.dll
rename C:\WINDOWS\system32\wudfplatform.dll den_wudfplatform.dll
rename C:\WINDOWS\system32\wudfcoinstaller.dll den_wudfcoinstaller.dll

Now run the umdf.exe and re-install.

Spent hours trying to fix this, and finally managed to get it working.

Hope it works out for ya, if it does, let me know!

In reply to an earlier post on Jan 31, 2013 3:30:06 PM PST
Didn't work for me.
The same error on MTP Device.

KFHD 7

Posted on Mar 28, 2013 1:14:50 PM PDT
Last edited by the author on Mar 28, 2013 1:23:21 PM PDT
I got this error message on Phillips gogear vibe and this is how I solved it.

I hope this helps : )

I want to give credit to: amrit bera blogspot mtp problem solved

He wrote a brilliant way to help my solve my problem.

The problem I got was:

There was a problem installing this hardware: MTP Device
An error occurred during the installation of the device.
The filename, directory name, or volume label syntax is incorrect.

The solution is to tick the below boxes:

1. no not this time ( skip this step and go to step 2, if this is not an option)

2. install from a list or specific location( advanced ), next

3. don't search. I will choose the drivers to install, next.

4. USB Mass storage device, next.

5. Finish.

It was that easy, and took about 3 minutes lol.

I wish they had a piece of paper to describe this information in the MP3 Player.

I recon this works on all devices.

I really hopes this helps.

Please post here if this info is correct. Just to let other people know if this works or not.

Posted on Dec 30, 2013 12:52:56 PM PST
Ethan C. says:
Tried the given steps but able to reinstall umdf but mtp is still not recognizable
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Paper white age 13 20 seconds ago
KINDLE KITCHEN #6: A place for sharing, caring, chat and FUN! 127 10 minutes ago
We're Quirky And We Know It! Come Witness The Howling Dink, Hussy Turkey Hens, And A Veritable Plethora Of Other Beasts! So Geese! 5746 16 minutes ago
Tax on Kindle books? 15 21 minutes ago
Fire stick drops network connection 1590 33 minutes ago
Kindle Fire 10 question 6 45 minutes ago
Elephants Three at The Ģrandest Hotel - Part IV 4969 1 hour ago
My Kindle Touch can't connect to my wifi router at home 25 1 hour ago
Echo Toilet Paper 6 1 hour ago
86th RAoK - Let the Games Begin 4413 1 hour ago
 

This discussion

Discussion in:  Kindle forum
Participants:  6
Total posts:  8
Initial post:  Oct 17, 2012
Latest post:  Dec 30, 2013

New! Receive e-mail when new posts are made.
Tracked by 5 customers

Search Customer Discussions