Amazon Vehicles Editors' Picks Amazon Fashion Learn more nav_sap_plcc_ascpsc $5 Albums Fire TV Stick Health, Household and Grocery Back to School Totes Summer-Event-Garden Amazon Cash Back Offer TheKicks TheKicks TheKicks  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis Celine Dion Water Sports STEM
Customer Discussions > Kindle forum

MY kindle fire wont load the book store.


Sort: Oldest first | Newest first
Showing 1-25 of 95 posts in this discussion
Initial post: Oct 22, 2012 6:34:12 AM PDT
M574R says:
My kindle is connected to my wireless internet. I have restarted my kindle and I have rebooted my router. All of my other devices are working on this network and my kindle is able to browse the internet. It will not load the bookstore and says that an error occurred and an internet connection is required to complete the task. I have also just purchased a kindle book online on my computer and had it sent to my cloud but I still cannot see it on my kindle.

Posted on Oct 22, 2012 9:22:50 AM PDT
Fud53 says:
Start with going to manage your kindle and send it to that device specifically(like most of us do). If that doesn't work go here: http://www.amazon.com/gp/help/customer/display.html?ie=UTF8&nodeId=508510

Posted on Oct 28, 2012 3:55:58 PM PDT
Robert says:
My situation is similar; if I click on one of my apps it will say unable to open application please redownload app from the amazon appstore and ill go to my appsrore but it will not load please help

Posted on Nov 5, 2012 5:32:27 PM PST
Chelsea says:
My kindle wont load anything at all. Ive shut it down n rebooted it sever times. My wireless is on n cinnected but it Won't access facebook, books, words with friends or any other app. How do i fix this??

Posted on Nov 5, 2012 5:32:40 PM PST
[Deleted by the author on Nov 5, 2012 5:32:58 PM PST]

Posted on Dec 18, 2012 9:45:14 PM PST
Linda Thomas says:
Just to add to this conversation in case anyone else is looking for a fix for this. This has happened to me a couple of times, and I fixed it this way. Go to your wifi, and click on your wifi name and then select forget. Reboot your rooter then when it's connected again, click on wifi again and this time connect and enter your password. You should find it now works. Much like some times you need to flush your dns cache on you laptop/desktop, I think that a similar thing happens on the kindle. By clicking forget and then restarting you router and reconnecting it seems to flush the settings. Hope it helps anyone else that's in need of a fix. Warmest, Linda

Posted on Dec 23, 2012 6:58:35 PM PST
that did not help mine...still wont load the app store

Posted on Jan 2, 2013 7:14:05 PM PST
K says:
Im having the same exact problems as Mckenzie Katherine Rudolph and Robert MIXED. Ugh ive gone to: with applications>third party applications> appstore and cleared cache and data. Ive done the same but web too. Please help!!:(

Posted on Jan 2, 2013 7:40:20 PM PST
Dolores Dawn says:
My problem was solved when I turned the kindle off, then on again.

Posted on Jan 2, 2013 7:56:34 PM PST
K says:
OMG GUYS I FIGURED IT OUT!!! Click the cog wheel or battery in the top right corner. Go to date&time and u can select network provided date and time or set ur own(i prefer my own, whenever i use network its false) but this has happened b4 several times to me and it always cracks up to this.

Posted on Jan 8, 2013 5:30:48 PM PST
Chip says:
THANKS K!

Posted on Jan 11, 2013 6:16:37 PM PST
when i turn on my kindle fire all i get it the black screen with Kindle Fire written on it. it wont load all the way up... PLEASE HELP!!!

In reply to an earlier post on Jan 11, 2013 7:57:10 PM PST
K says:
Try holding the button for 30 seconds, and when the 30 seconds is up release the hutton and click it once again. But just one simple click- no holding! Hope this helps:)

In reply to an earlier post on Feb 20, 2013 8:55:15 PM PST
L. Wilke says:
This worked and it helped a lot so thanks for helping me with this I'm so happy unnamed go play games now

Posted on Mar 3, 2013 2:16:56 PM PST
Last edited by the author on Mar 3, 2013 2:17:56 PM PST
I can open all of the Amazon Digital Stores through my Kindle Fire EXCEPT the book store. I've synched, reset everything, and "forgotten" my wireless connection and it still doesn't load. Any ideas would be most appreciated? Thanks.

In reply to an earlier post on Mar 3, 2013 5:38:57 PM PST
THANK YOU! that solved my problem too!! :)

In reply to an earlier post on Mar 5, 2013 7:16:12 PM PST
Teresa G. says:
I am having the same problem. If you come up with a solution please let me know. :-)

Posted on Apr 14, 2013 8:59:59 PM PDT
H. Irby says:
Thank you K!! I did the date&time set-up, then held the button for 30 seconds and clicked it once, when it came on my books were there, including the one I'd bought, but hadn't shown up on my kindle yet. Thank you so much for the help!!

In reply to an earlier post on Apr 19, 2013 7:39:51 PM PDT
great! says:
This just worked for me. Thank you.

In reply to an earlier post on Apr 22, 2013 7:10:03 PM PDT
Rochelle says:
Exactly my problem im conected to wifi and i can go on the web. But whe i clicked my apps it said i couldnt open them and it wont let me download anything

In reply to an earlier post on May 11, 2013 7:22:19 AM PDT
My kindle fire is doing the same exact thing

Posted on May 12, 2013 7:00:43 AM PDT
eddie says:
Hi looking for a fix, have had my kindle fire hd 6 months no problems, last week became very slow when trying to play music, takes an age to load device music. Have tried rebooting but didnt fix, very frustrating!

In reply to an earlier post on Jun 4, 2013 1:39:50 PM PDT
Thanks Linda that did the trick

In reply to an earlier post on Jun 4, 2013 6:56:38 PM PDT
Last edited by the author on Jun 4, 2013 6:58:41 PM PDT
ATD says:
Thanks. Linda's suggestion of "forgetting the network, shutting down, rebooting wifi router, then booking the KF and re-connecting via wifi" solved my issue. Simply rebooting kindle and/or forgetting network without resetting router inbetween steps did NOT fix it.

Posted on Jun 29, 2013 8:35:17 PM PDT
I haven't used my Kindle in about 2 weeks. When I turn it it it works perfectly. Then like an hour later it starts to act weird. It barely runs app. When I go on Youtube and press Play, it stays stuck on the loading screen. I don't know why it's doing this.
‹ Previous 1 2 3 4 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
OT: Discussion - (Freebie Books Links Only) 5450 9 minutes ago
Freebie Books - Links Only - No Self Promotion IV 8171 12 minutes ago
Battery life for basic Kindle (am I doing something wrong 3 17 minutes ago
wordwise enabled books in spanish 2 1 hour ago
Free Books and Chat - August 2016 766 1 hour ago
Kindle / Audible Recommendations and Deals (KARD) 3298 1 hour ago
Elephants Three at The Ģrandest Hotel - Part IV 4971 2 hours ago
86th RAoK - Let the Games Begin 4414 2 hours ago
We're Quirky And We Know It! Come Witness The Howling Dink, Hussy Turkey Hens, And A Veritable Plethora Of Other Beasts! So Geese! 5755 3 hours ago
Kindle Fire Slow WiFi 91 3 hours ago
 

This discussion

Discussion in:  Kindle forum
Participants:  70
Total posts:  95
Initial post:  Oct 22, 2012
Latest post:  Jul 14, 2016

New! Receive e-mail when new posts are made.
Tracked by 23 customers

Search Customer Discussions