Your Garage Best Books of the Month STEM nav_sap_plcc_ascpsc Samsung S8 Launch Limited time offer Luxury Beauty Handmade Mother's Day Gifts STEM Book House Cleaning DrWho DrWho DrWho  Introducing Echo Look Starting at $89.99 Kindle Oasis Nintendo Switch National Bike Month on Amazon disgotg_gno_17
Customer Discussions > Kindle forum

Kindle won't automatically download books anymore


Sort: Oldest first | Newest first
Showing 1-14 of 14 posts in this discussion
Initial post: Oct 5, 2013, 11:50:59 AM PDT
B. Roland says:
I have the Kindle with the arrow keys on the bottom, and up until recently, it downloaded books automatically just fine. All of a sudden though it has stopped. It has 700 mb free so that isn't the problem. In my manage kindle page on amazon I have 30 pending deliveries just sitting there but they won't send to my kindle. I have tried restarting it and it didn't work. It is connected to my wifi so I don't know what is happening. Any ideas?

Posted on Oct 5, 2013, 12:01:34 PM PDT
MYOHMY says:
I would call Customer Service at 1-66-321-8851. I have never waited for over 45 seconds to talk with someone and they have always helped me.

In reply to an earlier post on Oct 5, 2013, 12:27:53 PM PDT
Last edited by the author on Oct 5, 2013, 12:30:01 PM PDT
Carbonbased says:
It's still registered to your account, yes?

ETA: Also, have you recently pre-ordered a new Fire? I noticed that, unlike previous Fires, the HDX jumped to the top of my devices.

Posted on Oct 5, 2013, 11:29:36 PM PDT
B. Roland says:
It is still registered to my account. No pre-order either.

Posted on Oct 6, 2013, 2:32:04 AM PDT
I had that problem, shut the unit all the way down, then restart.. works for me

In reply to an earlier post on Oct 6, 2013, 3:01:15 AM PDT
Dragi Raos says:
"I noticed that, unlike previous Fires, the HDX jumped to the top of my devices."

Aaargh, another change that will make countless previous explanations of device list ordering invalid!

Thanks.

In reply to an earlier post on Oct 6, 2013, 3:06:29 AM PDT
Last edited by the author on Oct 6, 2013, 3:09:02 AM PDT
Dragi Raos says:
Let's try several things, checking after every test was the problem resolved:

- Verify that your WiFi connection actually works (say, by going to Store).

- Do a "Sync and look for new content" or whatever the wording is, from home page menu.

- Look into Cloud/Archive from your device. Are new titles there? What happens if you try to initiate download?

- De-register your device, re-register it, sync.

- Do a reboot: unplug the device, then press the power button and hold it for *full 30 seconds* (ignore the screen). Release, and leave the device alone for several minutes while it restarts, initializes and finds it bearings. Then repeat the drill from the beginning.

Good luck!

Edit: If push comes to shove, you can always temporarily switch to delivery over USB via computer. See https://amazon.com/kindletransfer

Posted on Oct 6, 2013, 11:42:05 AM PDT
B. Roland says:
I have tried everything except deregistering the account because for some reason when I click deregister, nothing happens. I am also trying to reset the Kindle to factory settings and that wont work either because when I click the ok button to reset, once again nothing happens. Is there a way to hard reset it by taking out a battery or something?

In reply to an earlier post on Oct 6, 2013, 2:26:52 PM PDT
Not without voiding the warranty.

Please tell us in detail what happens when you try each of Bufo's steps above.

In reply to an earlier post on Oct 6, 2013, 2:46:29 PM PDT
Carbonbased says:
That was Dragi channeling Bufo. I think it's time for B. Roland to click the 'help' icon top center of the webpage and have Customer Service call.

In reply to an earlier post on Oct 6, 2013, 3:19:31 PM PDT
So it was :-)

It could well be time for CS, but it still may be that actually finding out what happens on each of those steps would enable us to identify what's wrong. (Not to mention demonstrating that each of the steps has actually been tried; it wouldn't be the first time someone says "I've tried everything" when they haven't.)

Posted on Oct 6, 2013, 8:36:05 PM PDT
B. Roland says:
Just to humor you, here is what happens for each of the steps.

1.) I went to the kindle store and was able to browse around so the wifi definitely works.
2.) After doing the sync, it gave me a sync progress bar at the top, but it didn't actually sync any new books.
3.) When I went into the archives, there is nothing listed on the kindle.
4.) De-registering it didn't work because when I click deregister, the kindle did absolutely nothing. the popup just stayed there with the ok and cancel buttons. It wouldn't let me actually click the deregister button.
5.) I rebooted the machine several times both by using the power button and through the menus. It would boot up like normal and load the books but never the ones pending delivery.

In my amazon page, there are 30 pending deliveries and even when I manually click the actions button next to them and click send to device it doesn't work.

It has 700 mb free so space shouldn't be a problem. I was able to manually transfer a book through usb though.

In reply to an earlier post on Oct 6, 2013, 9:11:58 PM PDT
It sounds to me as if it has some glitch that makes it think it isn't registered at this point. Having nothing listed in the archives isn't normal unless all the books you've ever bought at Amazon are downloaded to your device.

Though there's one more possibility I can think of - how long are you actually giving it to download books? With 30 books pending, it could take a while, and they don't necessarily all download one after the other. After having the wifi on for several minutes, have you looked to see if you have the option to "view downloading items" in the home screen menu?

If nothing we've suggested solves it, I agree with it being time to call kindle CS (which we're not - we're just other customers). It will be helpful for them, though, if you can tell them all the steps you've tried and what happened with each.

In reply to an earlier post on Oct 6, 2013, 9:24:02 PM PDT
B. Roland says:
One other note which may be important is that I thought resetting the device to factory defaults may fix the issue. When I tried that though, the kindle did the same thing as when I tried to deregister it and did nothing. Just sat there with the button popup.

It has had plenty of time to download the books and hasn't changed in days. I appreciate everyone's help. Looks like its time for a call to customer support.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Cannot filter my Amazon wishlist by price drop 22 27 seconds ago
Identifying kindle book codes 18 2 minutes ago
We're Quirky And Proud Of It! Join Grace The Bichon, Mighty Mouse, Snapper, Wookie The Hound, Pear Eating Turkeys, Cats Playing Ice Cube Soccer And A Herd Of Giraffes! No Rude Big Goats Allowed! Tally Ho! 9654 3 minutes ago
Free Books & Chat - April 2017 823 6 minutes ago
KINDLE KITCHEN #6: A place for sharing, caring, chat and FUN! 6378 15 minutes ago
SwagBucks Thread 2016 2013 29 minutes ago
Freebie Books - Links Only - No Self Promotion IV 9484 30 minutes ago
Kindle Touch (D01200) 2 34 minutes ago
87th RAOK Let the winter fun begin! 7120 35 minutes ago
Multiple Kindle Windows on PC, Mac 24 36 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  6
Total posts:  14
Initial post:  Oct 5, 2013
Latest post:  Oct 6, 2013

New! Receive e-mail when new posts are made.