Bubble Witch Saga 3 Industrial Deals Most Anticipated Fall Children's Books Shop new men's suiting nav_sap_plcc_ascpsc Learn more about Amazon Music Unlimited Get 10% cashback on thousands of musical instruments with your Amazon.com Store Credit Card Starting at $39.99 Grocery Handmade Tote Bags Book a house cleaner for 2 or more hours on Amazon Fall TV Binge-worthy season premieres are here Fall TV Binge-worthy season premieres are here Fall TV Binge-worthy season premieres are here  Introducing Echo Show Introducing All-New Fire HD 10 with Alexa hands-free $149.99 Kindle Oasis, unlike any Kindle you've ever held Shop Now ToyHW17_gno
Customer Discussions > Kindle forum

Kindle App not working


Sort: Oldest first | Newest first
Showing 1-25 of 101 posts in this discussion
Initial post: Dec 20, 2013, 4:22:37 AM PST
JK says:
Since Microsoft updated my kindle APP will not open on my windows 8.1 when I click on the app it just flashes then goes back to start page.

Posted on Dec 20, 2013, 11:38:12 AM PST
I just get blank pages since updating my Android Kindle app.

Posted on Dec 20, 2013, 2:27:08 PM PST
The Kindle apl updated on my Motorola droid razr m and now the app does not work. I can uninstall the updates and then it works again until it updates then it does not work again. The app appears to have unregistered itself but you can't select the register option under settings to register it again. This stinks because I can't read books on my phone anymore.

Posted on Dec 20, 2013, 2:54:05 PM PST
Artist says:
You all need to delete the Kindle reading app from your device(s) and redownload it. Register it to the same Amazon account and download your books from the cloud.

In reply to an earlier post on Dec 21, 2013, 2:39:49 AM PST
Last edited by the author on Dec 21, 2013, 2:40:48 AM PST
JK says:
That does not work. My problem is when I delete it of my PC then reinstall the app it won't open so I cannot re-register it. I spoke to Amazon but they did not seem to know what to do, I was passed on to different people but no joy.

Posted on Dec 21, 2013, 1:05:01 PM PST
Pat says:
Since yesterday I get, unfortunately amazon kindle has stopped. I've uninstalled and reinstalled and still get the same message. I've just bought new books so I'm not happy!!!!!!!! Can anyone help please

Posted on Dec 23, 2013, 7:22:03 AM PST
I am having the same problem. The only thing the kindle app allows me to do is buy more books at the kindle store. Omg. I have to sit all day and look at a wall. This is hell.

Posted on Dec 23, 2013, 7:47:26 AM PST
Last edited by the author on Jan 3, 2014, 12:29:34 PM PST
T. Morman says:
I am having the same problem as Timothy M. Payne. The Artist says to remove and download the app again. Unfortunately, the app cannot be removed from the Motorola Razr M because the app was installed on the phone when it was shipped. The next best thing is to "disable" the app. No help there either. I have unloaded the updates as Timothy has suggested. After going to settings, I can get to the re-register screen. After registering, some of my books state that there are too many Android's already registered (ONE?). Then, the updates come again (cannot turn off the auto-update feature for Kindle app) and the process starts all over. Please back out the updates until the problems are fixed. Thank you. Additional info: You can go to the kindle app via Playstore and turn off auto-update, then uninstall updates, log into Amazon and delete the excess Android registered devices. Re-register the RAZR m. Problem solved until they fix the update issues.

Posted on Dec 24, 2013, 6:08:17 PM PST
Bob Lombardo says:
BL says:
It took me awhile to realize that it was the update that was putting my Razr M into the re-register loop. It was de-registering itself every time I powered off the phone and then powered up again. I spoke with the Amazon tech and his only suggestion was to try resetting the phone but he said there was no guarantee that would work. Every time I re-register the phone, I have to deregister the previous one online so my books will load. I have two Nexus 7's and both are working fine. Problem seems to be with the updates and the app furnished with the phone.

Posted on Dec 24, 2013, 7:04:51 PM PST
Last edited by the author on Dec 24, 2013, 7:43:39 PM PST
Retired EE says:
Normally pre installed apps can have their updates removed restoring them to the factory version without effecting anything else. If you do that then install the update that should be equivalent to a uninstall and reinstall. That won't work with the KF since the Kindle app is a part of the OS.

Did you know that the 4.3 version of the Kindle app released on 12/17 contains collections like the iPad Kindle app? I only see 4.3 on the Google Play Store while the Amazon App Store Kindle app is 4.2. It automatically installed on my 4.2.2 Jelly Bean tablet and phone but reverted to 4.2 or earlier when I reinstalled it on my 2.2 and 2.3 tablets. I saw a post that said it installed on a Nexus 7 with Kit-Kat.

Posted on Dec 29, 2013, 12:37:45 PM PST
Bibliophile says:
To use my kindle app on my razr phone, I have to disable all auto-updating, remove all updates on the kindle app and find whatever book I'm reading from the list of every ebook I've ever purchased. I hope they figure out what got broken in the last two updates and fix it, because this is getting old.

Posted on Jan 3, 2014, 12:13:36 PM PST
J Newton says:
I am not able to register my kindle on my android app. (Droid RAZR m) I've uninstalled and did the updates and nothing. just takes me to the home area with no books. :(

In reply to an earlier post on Jan 5, 2014, 7:36:46 PM PST
Tried this, did not work.

Posted on Jan 5, 2014, 7:45:42 PM PST
I fixed mine from a thread on a Android Kindle site. You must disable your Kindle app and download the app BuildPropEditor. Open that app and go down to ro.product.manufacturer. Change the manufacturer to Asus. Don't reboot when it recommend it. Change ro.product.model from your model name (mine says XT907) to Nexus 7. Reboot your phone. When it restarts, enable Kindle, but DON'T update. You should be able to register and view your Kindle purchases. Don't let the app update or you will have to do this all over again. Hopefully Amazon fixes the app soon.

In reply to an earlier post on Jan 14, 2014, 6:02:49 PM PST
I tried deleting the updates and de-selecting the auto-update option but it is still not working. Your solution of deleting the app is not working for those of us with a factory-installed application (such as on some motorola phones).

In reply to an earlier post on Jan 14, 2014, 6:07:45 PM PST
Artist says:
Have you contacted customer service? They're the ones who might know, not other customers.

Posted on Jan 14, 2014, 6:27:18 PM PST
Nellie87, thank you for offering a different solution, however it did not work for my phone (motorola droid razr HD - even when I reboot it reverts back to the default settings). Still wondering how I can access hundreds of dollars worth of books on my phone...

In reply to an earlier post on Jan 14, 2014, 7:24:05 PM PST
Artist says:
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

In reply to an earlier post on Jan 17, 2014, 11:07:32 AM PST
Customer service was able to help today.

In reply to an earlier post on Feb 1, 2014, 2:18:29 AM PST
I agree!! I'm so irritated with this. Every time I turn around I have to go through this same thing. Frustrating!! I thought I would try this app on my phone to see if I would want a real-kindle. Now, I'm wondering if I even dare get an ebook.

In reply to an earlier post on Feb 5, 2014, 1:48:29 PM PST
Monty Steele says:
What was the solution?

In reply to an earlier post on Feb 6, 2014, 2:14:39 AM PST
I usually still have to re-download the entire thing before I can read. still frustrating.

Posted on Feb 9, 2014, 9:40:30 PM PST
Yeah, I've got the same thing, except now that I am attempting to reinstall Kindle, I can't even log onto my Amazon account from my phone. Nice.

Posted on Mar 17, 2014, 1:09:59 PM PDT
downloaded the kindle app but it will not work, message says kindle stopped working! Help

Posted on Mar 25, 2014, 10:09:10 AM PDT
Last edited by the author on Mar 25, 2014, 10:13:33 AM PDT
JC Gillmore says:
CNET App Hangs on Kindle Fire? It use to work but has now stopped. Removed and re-installed but no joy. Loads initially, but when I select an item to read, it hangs with a blank screen. Appears to attempt to load item, then hangs and drops communication or runs out of memory? No messages.
‹ Previous 1 2 3 4 5 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
FREE Books & Chat - September 2017 635 7 hours ago
I think my account got hacked. 37 7 hours ago
We're Quirky! There Are Various Critters, Including Tail-less Manx Kittens, Here. We Also Have Hugh Manatee. Bring Your Quilting And Sewing Projects, Your Camera, And Your Instant Pot. So Geese And Tally Ho! 4569 7 hours ago
Kindle HD 7 arrow in status bar 20 7 hours ago
Discounted / Price Dropped Kindle eBooks IV 2867 7 hours ago
Elephants Three at The Ģrandest Hotel - Part IV 6640 8 hours ago
Can't find book on my Kindle 54 8 hours ago
Removing ads from lock screen on 2016 hd fire tablet 24 9 hours ago
KINDLE KITCHEN #6: A place for sharing, caring, chat and FUN! 9252 9 hours ago
How can I speak to someone at Amazon? 188 9 hours ago
 

This discussion

Discussion in:  Kindle forum
Participants:  82
Total posts:  101
Initial post:  Dec 20, 2013
Latest post:  14 days ago

New! Receive e-mail when new posts are made.
Tracked by 33 customers