Amazon Vehicles Up to 80 Percent Off Textbooks Amazon Fashion Learn more Discover it $5 Albums Fire TV Stick Health, Household and Grocery Back to School Totes Amazon Cash Back Offer ElvisandNixon ElvisandNixon ElvisandNixon  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis GNO Back to School STEM
Customer Discussions > Kindle forum

Problems w/ WiFi connection on Kindle Fire?

Sort: Oldest first | Newest first
Showing 1-25 of 906 posts in this discussion
Initial post: Nov 15, 2011 7:18:40 PM PST
We got the Kindle Fire today & have had a very hard time establishing a connection to our home wifi network. We have never had problems w/ other device, but the Fire will not connect - it times out.

Anybody else have problems or know of a fix?

Posted on Nov 15, 2011 7:28:10 PM PST
TerryB says:
There are many many threads reporting the problem. There's so far been no one universal fix. You should probably go ahead and contact CS and also peruse the threads to see what others have tried.

For lots of folks, updating to 6.1 seems to have helped but the Catch-22 is when you can't connect to wifi in order to download the update. Some have been able to successfully connect their Fires to their PC's and sideload the update but others are reporting their pc's don't recognize the Fires.

In reply to an earlier post on Nov 15, 2011 7:28:21 PM PST
Artist says:
Contact cs for assistance., click on the contact us button.

Posted on Nov 16, 2011 10:44:35 AM PST
Mark says:
I have been having nothing but wifi issues since it arrived. Three different networks, all the same problem. Trouble connecting at first and then when it does, it appears to timeout and drop the connection. It doesn't matter what I'm doing at the time for it to drop the connection. Upon a restart or re-entering the network it refuses to reconnect. I did contact CS and after troubleshooting, they bumped it up for to their development team review.

Posted on Nov 16, 2011 10:46:57 AM PST
Ernie says:
Tried downloading the update and applying it manually?

In reply to an earlier post on Nov 16, 2011 10:55:19 AM PST
Mark says:
I did. I actually downloaded and updated before I knew there was an issue. I've tried most everything I could think of to troubleshoot including deleting and adding the network back in. I'd blame the network if I wasn't experiencing the same symptoms in multiple locations with different types of logon (some open, some closed).

Posted on Nov 16, 2011 11:08:55 AM PST
Mary Ellison says:
I had an initial promble connecting to a Verizon MiFi mobile, but after backing out and retrying from scratch, while clicking to show all ids and passwords, I connected successfully.

Posted on Nov 16, 2011 11:08:56 AM PST
Malachi says:
I posted this in another thread and thought I would post here too as it might help. It might not too.


I purchased the baby Kindle (the $79/$109 Kindle) when it first came out, only to discover that it had the most difficult time connecting to my Wi-Fi access point(*). Sometimes taking as long as 6 minutes to connect. I have several other Wi-Fi devices, including a Kindle 3, all of which have no problem at all connecting to the access point (AP).

The AP is setup to use WPA2. It was also set for B/G/N compatibility. I discovered, while playing with the settings, that if I made it G-mode only, the baby Kindle began connecting immediately. After further playing around with it, I discovered that with it set to G/N-mode the baby Kindle continued to function properly. And, if I re-enable B-mode compatibility the baby Kindle again began to become finnicky, taking several minutes to connect.

Since I don't have any devices that require B-mode on the access point I now leave it set to G/N-mode only and the baby Kindle is happy.

I present this only as information. Something you may want to try with your router.

(*) Since I already have a hardwired router on my network which provides routing functions, I have DHCP disabled on my Wi-Fi router. Hence, my use of the term 'access point'.

Posted on Nov 16, 2011 1:57:46 PM PST
J. Harrison says:
I just got my kindle fire and cannot get a WIFI connection (from any location). This is very dissappointing product experience. I've been waiting on CS to contact me now for 8 hours. No response.

Posted on Nov 16, 2011 3:22:20 PM PST
No problem with my Fire. I plugged it into the charger & opened it, the Fire connected to my Wireless Network & connected to the Internet when I tried that. The Fire also immediately downloaded & applied the update. DARN glad I had no problems. I was nervously fearing problems after reading a lot of comments here.

Posted on Nov 16, 2011 3:27:52 PM PST
Cindy G. says:
I had the same issue connecting initially, and even with CS on the phone, we weren't getting anywhere...

What did finally work was this - I manually downloaded/installed the 6.1 update, and then pushed the reset button on my router - this finally made it work. Power cycling the router didn't help, I had to actually reset it.

In reply to an earlier post on Nov 16, 2011 3:30:31 PM PST
Malachi says:

If you reset your router then it's lost any security settings that it was configured with, which means, unless you've set those back up, your router is likely wide open right now.

In reply to an earlier post on Nov 16, 2011 3:34:39 PM PST
Mark says:
Just wondering, did you reinstall the update or just install it that way from the get go. I hate to think that this is necessary when all other wireless devices connect fine (including the kindle 2 and kindle keyboard).

Posted on Nov 16, 2011 3:43:07 PM PST
Lynn M says:
I had wifi issues yesterday, but today it's fine!

In reply to an earlier post on Nov 16, 2011 4:05:16 PM PST
Same problem. Contacted CS. Could not fix problem after 1 hour on phone. Rep escalated to "specialists"; will call me back in 24 hours. And so it continues.

In reply to an earlier post on Nov 16, 2011 6:18:30 PM PST
[Deleted by the author on Nov 16, 2011 6:19:39 PM PST]

Posted on Nov 16, 2011 6:19:21 PM PST
Last edited by the author on Nov 16, 2011 6:43:00 PM PST
I too had this problem. I even took it back to Best Buy and they showed me they were able to connect and maintain a wi-fi connection. I came home, did a hard reset on the wi-fi router. And then did a reinstall of the wi-fi router. I even changed my password to something new. Once I was up and reconnected to the internet, I turned on the Kindle Fire and typed in my new password and it connected right away.

I did notice my security setting was "WEP" and most all of the other available wi-fi connections near me were set at "WPA/WPA2", so when I reinstalled the router I selected this same option.

In reply to an earlier post on Nov 16, 2011 6:21:00 PM PST
[Deleted by the author on Nov 16, 2011 6:40:14 PM PST]

In reply to an earlier post on Nov 16, 2011 7:47:42 PM PST
PowerShopper says:
Yes. I have the same problem.. I am going to try to exchange mine.

In reply to an earlier post on Nov 16, 2011 7:53:20 PM PST
Malachi says:
It is good that you switched it to WPA. WEP was cracked a number of years ago and is so easy to by-pass that any script-kiddie can do it in a matter of minutes. It is effectively no security at all.

Posted on Nov 17, 2011 12:03:38 AM PST
K. Wiens says:
I was finally able to connect to my wifi home network by simply adding the MAC address of my Kindle Fire in the Network Settings screen. There is a section where you can add devices. That worked and its been connected and working beautifully ever since. I use WPA2.

Posted on Nov 17, 2011 12:27:41 AM PST
Ade Miller says:
I've tried everything listed here. It seems after further experiments with switching off and on; WEP, wireless mode (b/g or g), MAC filtering and static IP on the KF that the issue for me is DHCP related. If I use a static IP configured on the KF things work OK and I can connect to the WiFi network and if I use DHCP all I get is the "Attempting" status on the Wireless Networking connection screen. I have an older Microsoft MN-700 Wireless router. Yes this is pretty old and I should replace it but this is the first device I've had that refused to connect to it; Kindle 2, several phones, laptops, notebooks (mine and friends) all work just fine so I suspect this is a KF issue.

Obviously static routing isn't really a long term solution so I hope this gets fixed with another update.

The KF seems pretty nice, I got to play with it while messing around with the WiFi. However I really didn't come home from work at 11pm to do tech support and the actual owner of the KF is somewhat underwhelmed with her new toy. Pity, because I _really like my Kindle and have nothing but good things to say about it.

Posted on Nov 17, 2011 12:42:06 AM PST
Charles says:
I'm on the phone now with amazon kindle support line in Africa. When we first turned on the kindle fire it uploaded an update and now reports its system version as 6.1_user_2017120 but the person on the phone tells me the device does not show that it updated on their screen. I explained that all I can do is tell them what this device is telling me...oh now they hung up on me lol nice to know I'm getting first class service from amazon. To bad it was going well for a few hours before it decided that it won't work with my wifi. A little research shows the the fire is using an older WL1270B 802.11 b/g/n Wi-Fi solution. the WL1270 is an older chip designed to work with the TI OMAP 3530 but the kindle fire uses the newer OMAP 4430 TI (Texas Instruments) processor. There are more reports coming in all the time about this wifi bug guess I need to try the nook color 2 or a 7" full android tablet, at this point an extra $50 for something that may work would be worth it.

Posted on Nov 17, 2011 1:25:22 AM PST
salsaguy says:
I have had issues with my wifi on my new Fire.
Its very finicky and usuallu only gets 2/4 bars sometomes 3/4 bars signal whereas my laptop in the same room will get 4/5 or 5/5 bars.
Not as good a receiver in the Fire I guess :(
Only got 4 bars on the Fire when it was placed right next to router antenna.
I have Verizon DSL 3MBps plan and a router with wifi on.
Its been connecting ok but loses it signal a lot as well and trying to surf the web is not working well at all and a waste for me

I am thinking of getting a wifi repeater?

I may try some settings.

I saw that some other house had the same channel used as mine so I might try switching channels to one no one else uses to prevent bleed over.

I'm using one of the forms of WPA I believe.

The 1st update to 6.1 took 15 mins! and disconnected a few times I had to restart it a few times to get the the full update patched on my 1st try

Posted on Nov 17, 2011 5:26:31 AM PST
Last edited by the author on Nov 17, 2011 6:06:36 AM PST
Namaste53 says:
I had the same problems when I received my KF yesterday. Wifi connection kept dropping constantly. Spoke with a very patient and helpful tech support rep and the problems are now resolved. I already had the latest version of the KF software, so that wasn't the issue. He told me to unplug my modem and at the same time hold down the power button on my KF for about 30 seconds. Then I plugged in my modem again, my KF rebooted, and now my Wifi is working perfectly. Seemed like this was needed for the modem to recognize the new device, or something to that effect.
Other people's modems and system configurations may be different, but in my case this simple solution worked well.
‹ Previous 1 2 3 4 5 6 7 8 9 10 ... 37 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
How to download a etextbook to iPad 2 2 minutes ago
Can't highlight text in some books in my Kindle Fire 4 10 minutes ago
Discounted / Price Dropped Kindle eBooks IV 19 11 minutes ago
Box app 1 15 minutes ago
Elephants Three at The Ģrandest Hotel - Part IV 4982 17 minutes ago
Wh do my new books I order go straight ot archived?? 1 17 minutes ago
Fire TV #1 Remote does not work anymore. 0 21 minutes ago
Potentially Perky People - Part Deux 7931 22 minutes ago
Free Books and Chat - August 2016 826 23 minutes ago
Australian/Kiwi kindle users thread #4 - "the BBQ" 6773 29 minutes ago

This discussion

Discussion in:  Kindle forum
Participants:  522
Total posts:  906
Initial post:  Nov 15, 2011
Latest post:  Jul 19, 2016

New! Receive e-mail when new posts are made.
Tracked by 76 customers

Search Customer Discussions