Customer Review

The manufacturer commented on the review belowReviewed in the United States on April 28, 2020
I purchased this through Amazon eight months ago and I wish I never had. I spent a lot of money on the PR4100 as well as 4 10tb drives. About three weeks ago it started informing me there was a "power loss on port 1." I thought it was unusual because it continued to work with no problem. I wrote to WD and they recommended checking to see if the other port worked. When I tried the other port, the PR4100 went through the (ridiculously long) initialization procedure, then I got a red light and it stopped working. I transferred power back to the other port and I got the same response. Now both ports won't work. I contacted tech support and spoke with one of the worst support persons I've ever dealt with. He clearly couldn't have cared less and every time I asked a question there was silence for 25 seconds before he'd finally give me an answer (and it wasn't due to a time delay). Now I'm sending it back to WD so they can send me a "refurbished replacement" (although I bought mine new) which could take weeks, according to the support person. I also didn't get a clear answer to my question as to whether the next one I get will be able to read my 4 disk drives ("That depends," he said, after another long silence). I have close to 27tb of video files on them that I'll never be able to replace. I'm very sorry I purchased this product. I thought it would be a safe way to store files, but it's actually turned out to be the opposite.
8 people found this helpful
11 comment Report abuse Permalink

Product Details

4.1 out of 5 stars
4.1 out of 5
285 global ratings