Lyft Industrial Deals Beauty Best Books of the Month Shop new men's suiting nav_sap_plcc_ascpsc Learn more about Amazon Music Unlimited PCB for Musical Instruments Starting at $39.99 Grocery Handmade Tote Bags Book a house cleaner for 2 or more hours on Amazon Fall TV Binge-worthy season premieres are here Fall TV Binge-worthy season premieres are here Fall TV Binge-worthy season premieres are here  Introducing Echo Show Introducing All-New Fire HD 10 with Alexa hands-free $149.99 Kindle Oasis, unlike any Kindle you've ever held Shop Now FFII_gno
Customer Discussions > Kindle for Android forum

update problems

Sort: Oldest first | Newest first
Showing 1-25 of 33 posts in this discussion
Initial post: Jan 11, 2012, 4:00:04 PM PST
Dana says:
I updated my kindle app for android last night (which was working just fine before it was updated) now it wont load. It just force closes everytime! Is there anywhere to download an older vesion of the app for android? I have tried uninstalling and reinstalling and that did nothing to help. Sad :o(

In reply to an earlier post on Jan 26, 2012, 10:48:48 AM PST
Trish says:
Am having the same problem and I cant find the older version. I wish I had listened to the reviews that mentioned that its just a headache. Please let me know if you manage to find the older version. I wonder if anyone even bothered to test the software before its release.

Posted on Feb 24, 2012, 12:36:24 PM PST
Thelma Banks says:
keep forceclosing

Posted on Feb 28, 2012, 8:38:22 AM PST
Sassione says:
So all the books that I downloaded are just sitting there now that this "new and improved" version has been downloaded to my phone. How do we get back to the old version???? C'mon Android Marketplace, work with us!!!

Posted on Mar 23, 2012, 4:35:19 PM PDT
im having the same problem and i was in the middle of a great book.

Posted on Mar 25, 2012, 5:52:32 AM PDT
Last edited by the author on Mar 25, 2012, 6:24:02 AM PDT
Woad Warrior says:
I am also suffering from this problem. I called customer service about the problem and after trying several things to get it running again, I was told "We'll get back to you tomorrow.". Well, I guess tomorrow never comes. (I called 4 days ago.)
(Edit) I found this site on another post that has a library of past versions of many apps including the kindle app. I was able to find a version that ran on my device and can once again access my books.
You will want to use the download link from the site instead of the market link, since the market link will just give you the most recent version.

In reply to an earlier post on Mar 29, 2012, 12:28:42 PM PDT
R Verry says:
I must have been one of the first to notice this problem. After attempting to load the program on my Android smartphone, it crashed and the Android OS force closed it. I then uninstalled the application which rolled it back to the version installed as a system program when I initially purchased the phone. For the last 10 days, I have been unable to upgrade it having been stuck at version 2.1. At least I could still read my books and until now, never know that I was better off then some folks out there.

Working with Amazon customer support was with mixed results. While the front line help desk person kept in communication with me for the most part, the escalated ticket to the development team produced ZERO results. Using the App Store to update always returned an error message and the app never updated.

Finally, as a measure of last resort, I just went to the Amazon web site to see if I could download the app and install it outside the app market environment. Strangely enough, it worked. I down loaded the Amazon App Store, from which I could then download the Kindle for android app and install it. I'm pleased to report, that I am on the latest release 3.5.1 which is a patch release to fix the unexpected crash. Happy reading from now on. Perhaps my experience will help you.

Posted on Apr 17, 2012, 10:22:43 AM PDT
M. Deese says:
I don't know if anyone else is looking for an older version of the Kindle for Android app but does have several versions of the kindle and other apps. I found it when looking for the older versions of Kindle since the version on here never worked properly on my Coby Kyros tablet and the newer versions of the app could not be downloaded onto my Pandigital Novel tablet because the os is 2.1.

In reply to an earlier post on Apr 17, 2012, 11:14:32 AM PDT
Sassione says:
Thank you so much!! I'm back to the old version and it loads quickly. I can once again read my books.

Posted on Apr 17, 2012, 11:34:46 AM PDT
Dana says:
You are fantastic! It works like a charm now :o)

Posted on Apr 18, 2012, 10:36:40 AM PDT
Thank you! I also downloaded an older version and it works so much better!! Takes up much less space too! :)

Posted on May 4, 2012, 12:14:53 PM PDT
Kindle wont reinstall

Posted on May 4, 2012, 2:04:15 PM PDT
R Verry says:
I've got to say the older version is so much better and I'm going back to it. These latest versions are problematic, constantly losing their place even with good access to either wireless or 3g. I'm very disappointed with the product.

In reply to an earlier post on Jun 9, 2012, 3:52:09 PM PDT
dizzy4izzy says:
I have had the same experience. I am so frustrated. I loved my Kindle for Android before the up date that says it will fix problems, I did not have!

In reply to an earlier post on Jun 14, 2012, 4:48:18 PM PDT
LV 702 says:
Thank you soooo much. It worked like a charm. I was able to get the older version 3.2 from downloaded it. It worked all my books just popped back in. Even customer service couldn't help me. Thanks hope others seee this and try it.

Posted on Jun 14, 2012, 7:44:50 PM PDT
Lynn says:
Downloaded the newest version. Then downloaded some children's books. Now my kindle app keeps force closing. Any suggestions?

Posted on Jul 22, 2012, 12:44:05 PM PDT
[Deleted by the author on Jul 22, 2012, 12:47:27 PM PDT]

In reply to an earlier post on Aug 2, 2012, 12:01:36 PM PDT
Thanks a lot!! I am back and able to read my kindle books, version 3.0 works fine on my MW8650 tablet. now if we can make kindle understand that it is not the tablet but the new kindle version.

Posted on Sep 29, 2012, 8:06:34 PM PDT
i used the to get the old version and i am able to open and read my books again

Posted on Oct 15, 2012, 8:51:06 PM PDT
Manyjewels says:
Has anyone experienced difficulty when buying books using the Kindle app for android? When I go to the Kindle Store on my Motorola Xoom, I have to tap several times to buy books or get samples. Also, if I'm reading a review and get to the "Read More" section, it's virtually impossible to get it to show the extended content, no matter how many times I tap the underlined section. This never happens when I'm using any other app on the Xoom. It also takes a while to actually download purchased books and when it is downloaded and says "Read Now", I can't access the new book from that place. I have to use the arrow and go back to the list of books and sometimes wait for the book to appear on the page. I also have experienced having to download a sample in order to get the full version of the book after I have purchased. What I mean is, the full version of the book I've purchased sometimes does not appear in my list or on the list page unless I ask for a sample. Then the sample and the complete purchased book appear. Any suggestions will be appreciated.

Posted on Oct 15, 2013, 7:31:41 AM PDT
Tall Bill says:
I just had an automatic update of my kindle app last night and now I get a message "Unfortunately, kindle must stop". I have re-booted with no change. From this discussion it sounds like I may need to install an older version. However, most of these posts are more than a year old. Is anyone else having problems with the newest update (10/14/2013)?

In reply to an earlier post on Oct 15, 2013, 8:41:27 AM PDT
Manyjewels says:
I am also having problems with the new app, however, not the same as yours. When I go back to the home page, that has all the book titles on the Kindle, instead of exiting to that page, it takes me to an earlier page in the book. Since I don't always know my location or page number was on, I have to page forward through each page and try to find where I was last reading. Also, I am unable to use the "sync to last page read" successfully; it doesn't work on this app. In other words, there is a sync problem with this new version. It does not show as a usable, lighted function on this app. So far, it hasn't told me it has to stop, but I do not like the updated app. I hope Amazon developers read our posts and fix these problems.

Posted on Dec 16, 2013, 3:59:53 AM PST
Last edited by the author on Dec 23, 2013, 3:35:40 AM PST
Gretpass says:
I just installed the slightly older version of the Kindle app from and I was finally able to register my Kindle for Android app again and my books are back.

Be sure to check the next page here. David Limiero has another solution.

Posted on Dec 21, 2013, 12:21:22 PM PST
Peg R says:
The latest update has left me unable to see any of my books. I have to go into Settings and wipe out all of the updates. Then I have to re-register. This happens every time I go back into the Kindle app on my phone and started four days ago. When will there be an Android update that fixes this? I have loved this app up until now. Please fix it.

In reply to an earlier post on Dec 21, 2013, 7:57:04 PM PST
This started happening to me, too, on the same day. It's clearly a problem with the latest update. I have to reset to the factory version and re-register every morning to get my books back. The app came pre-installed from Verizon, the settings don't seem to allow me to prevent it from auto-updating. I had to disable auto-updating for ALL my apps...
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in


This discussion

Discussion in:  Kindle for Android forum
Participants:  28
Total posts:  33
Initial post:  Jan 11, 2012
Latest post:  Oct 27, 2014

New! Receive e-mail when new posts are made.
Tracked by 14 customers

This discussion is about